summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-02-13 10:47:17 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-02-13 11:00:46 +0100
commit349930fad5ac9642d38674f01f775e38de054840 (patch)
tree56878b2b3ac5c3d40b10d18165ce2d30c4ec045b
parentdev-build/b2: inject -pthread for glibc<2.34 (diff)
downloadgentoo-349930fad5ac9642d38674f01f775e38de054840.tar.gz
gentoo-349930fad5ac9642d38674f01f775e38de054840.tar.bz2
gentoo-349930fad5ac9642d38674f01f775e38de054840.zip
app-office/homebank: add 5.7.4
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--app-office/homebank/Manifest1
-rw-r--r--app-office/homebank/homebank-5.7.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
index 339ca656bb82..b769d3f10e92 100644
--- a/app-office/homebank/Manifest
+++ b/app-office/homebank/Manifest
@@ -1,2 +1,3 @@
DIST homebank-5.6.5.tar.gz 3399365 BLAKE2B 7a50694a3a42f742583d150b785ebb3e30efe4a5571e1076f8181fbd9e8c089b815b1157f98f8db96abae03ff97fdd6415c1d664379bfaa94acf9d0de470b1a0 SHA512 7cbf1f22275d44a5b6811512f76e96ec2946150fd5c7897ec364a597c037175f79ddc846e24d22ed5d81589cb88a918387c17470f6b9406d2a8a164b73f1364b
DIST homebank-5.7.3.tar.gz 3663021 BLAKE2B c290e8fb7776975b0cdb63fdba5f1272d36b62e295723d4b129ed39933fb5fd7987de08536abb5ac2ab3ce3f70e66be3a8d159bc0258834fe3be79ad0ba41788 SHA512 516809ae95873f70d44995093ebe981e70cf2111490db19dbac1d4f4df95fec9bd21c56eea3d91bf4c81e58de4277da035297e9eb6a0d1fd4450dbff764c0ba1
+DIST homebank-5.7.4.tar.gz 3670067 BLAKE2B 3be94dc9e1ec11fc67fb7dab1655c9e2ab8529887cba200331e938b02a97abf810d94823443de0f5faf1b6beda85f9208e26909a876c3828ae2a1aab38890db0 SHA512 d65127b49a7566f5ad88feb8c614883c43e322ea50d915e49691b169771fac222573da4988ab1c54d9f39b9dfdf2d724cba07269e093c67a04900828d0b87093
diff --git a/app-office/homebank/homebank-5.7.4.ebuild b/app-office/homebank/homebank-5.7.4.ebuild
new file mode 100644
index 000000000000..50acc70e5465
--- /dev/null
+++ b/app-office/homebank/homebank-5.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="https://www.gethomebank.org/"
+SRC_URI="https://www.gethomebank.org/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.39:2
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}