summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-31 01:43:16 +0000
committerSam James <sam@gentoo.org>2022-01-31 01:43:48 +0000
commit34b20a2a80202eb26b8146fd84e57d25890d6aa1 (patch)
tree709fd860f82b96d1b658a04f9d2c3fd49183f3e1
parentapp-emacs/racket-mode: bump to 20220129 (diff)
downloadgentoo-34b20a2a80202eb26b8146fd84e57d25890d6aa1.tar.gz
gentoo-34b20a2a80202eb26b8146fd84e57d25890d6aa1.tar.bz2
gentoo-34b20a2a80202eb26b8146fd84e57d25890d6aa1.zip
media-video/atomicparsley: add 0.9.6_p20210715_p151551 (fork)
Switch to fork with some CVE patches and build system fixes (changed to CMake from homebrew build script which e.g. didn't notice errors). Closes: https://bugs.gentoo.org/832361 Bug: https://bugs.gentoo.org/713696 Bug: https://bugs.gentoo.org/806845 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/atomicparsley/Manifest1
-rw-r--r--media-video/atomicparsley/atomicparsley-0.9.6_p20210715_p151551.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/media-video/atomicparsley/Manifest b/media-video/atomicparsley/Manifest
index 928a889fce2d..d7149321a8bb 100644
--- a/media-video/atomicparsley/Manifest
+++ b/media-video/atomicparsley/Manifest
@@ -1 +1,2 @@
DIST AtomicParsley-source-0.9.0.zip 172616 BLAKE2B 6e2fa904cde622524ec51e3d084d89dd86c04db9942a27fae67b0d12db0542705d28e723c26db94d234f26c7249c6b8d4fd01a2bce891d2310a3a912667e1d84 SHA512 a4733893bb0d8bf824ee46d7da7f8c2ab9338ae56ea89810db1ac40282554e7e095b3e88631786b248a66aba878f166b9ac403769c66ef3ad45ac8ff7d411982
+DIST atomicparsley-0.9.6_p20210715_p151551.tar.gz 230214 BLAKE2B 986058a8e80b84f30df03f5dfc6e2019ef6949469d8554a5a06ecc75716463b3047820265fd22556f9087a64498e07e994fa2162660f440086eab276be496a9d SHA512 9f58fe7426c9728f8e5624250ff57d7707a4b040365135fa5149909d84c536ecbddaa3820dae85ca8a4c31fc8009685bf56875f1d4ff6f5c854f05a30da6974a
diff --git a/media-video/atomicparsley/atomicparsley-0.9.6_p20210715_p151551.ebuild b/media-video/atomicparsley/atomicparsley-0.9.6_p20210715_p151551.ebuild
new file mode 100644
index 000000000000..c7c7cea6bd6c
--- /dev/null
+++ b/media-video/atomicparsley/atomicparsley-0.9.6_p20210715_p151551.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# The fork at https://github.com/wez/atomicparsley uses unusual versioning, so
+# we sadly need to hardcode the hash and update it per-release.
+MY_COMMIT_HASH="e7ad03a"
+MY_PV="$(ver_cut 5).$(ver_cut 7).${MY_COMMIT_HASH}"
+inherit cmake flag-o-matic
+
+DESCRIPTION="Command line program for manipulating iTunes-style metadata in MPEG4 files"
+HOMEPAGE="https://github.com/wez/atomicparsley http://atomicparsley.sourceforge.net"
+SRC_URI="https://github.com/wez/atomicparsley/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+src_configure() {
+ # APar_sha1.cpp:116:47 and 117:43: warning: dereferencing type-punned
+ # pointer will break strict-aliasing rules
+ append-flags -fno-strict-aliasing
+
+ cmake_src_configure
+}
+
+src_test() {
+ ln -s "${BUILD_DIR}"/AtomicParsley || die
+ tests/test.sh || die
+}