summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 16:47:22 +0200
commit354312535330f4dbf86b4df73d73255929fe3ae9 (patch)
treedbed83d61a77f2125ee0d4af795b2b2eb9545631
parentdev-python/flaky: Remove old (diff)
downloadgentoo-354312535330f4dbf86b4df73d73255929fe3ae9.tar.gz
gentoo-354312535330f4dbf86b4df73d73255929fe3ae9.tar.bz2
gentoo-354312535330f4dbf86b4df73d73255929fe3ae9.zip
dev-python/flask-debug: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-debug/flask-debug-0.4.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/flask-debug/flask-debug-0.4.3.ebuild b/dev-python/flask-debug/flask-debug-0.4.3.ebuild
deleted file mode 100644
index 8a4e915c7738..000000000000
--- a/dev-python/flask-debug/flask-debug-0.4.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="Flask-Debug"
-DESCRIPTION="Flask extension that displays various debugging insights during development"
-HOMEPAGE="https://github.com/mbr/Flask-Debug"
-# PyPI tarballs don't include tests
-# https://github.com/mbr/Flask-Debug/pull/2
-SRC_URI="https://github.com/mbr/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/inflection[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- sed -i "s/, 'sphinx.ext.intersphinx'//" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}