summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-07-01 16:33:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-07-01 16:34:52 +0000
commit35f27e35feadcadf781372e974ba2de866642d1f (patch)
treeae76defdc489695157b7a5fdae6552bab3fdbf97
parentdev-db/timescaledb: add 2.11.1 (diff)
downloadgentoo-35f27e35feadcadf781372e974ba2de866642d1f.tar.gz
gentoo-35f27e35feadcadf781372e974ba2de866642d1f.tar.bz2
gentoo-35f27e35feadcadf781372e974ba2de866642d1f.zip
games-board/stockfish: add 16
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--games-board/stockfish/Manifest2
-rw-r--r--games-board/stockfish/stockfish-16.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
index 46402e3653e0..61a3b6e5deb3 100644
--- a/games-board/stockfish/Manifest
+++ b/games-board/stockfish/Manifest
@@ -9,3 +9,5 @@ DIST stockfish-15-nn-6877cd24400e.nnue 47001499 BLAKE2B 12d9c250e7fc920aa1c575bd
DIST stockfish-15.1-nn-ad9b42354671.nnue 47001499 BLAKE2B ae4caa4c7c68941fe57b03fe6c8df996dad9138e7a53caad6f08e3c8ce924c9445ecfba9f8ff3091380d4d7b0b932cff654ded7758b3abcec934cd322bf73418 SHA512 25114b2ada67cf1dd8a0a5ff78eb3b48e8406fb3e3851753d1293acf2512878856fac6c171e65b9d186e639482fd34e2b80553a1331ed73c7d40f85460a46d42
DIST stockfish-15.1.tar.gz 193408 BLAKE2B 53f90d1ec35a96e804dc572ccc53f94b7d16686e02fb1c490f22129c313d74f39c3beeadf896016a0e0bdf9fd01bfec2f78efcaa1261869fbb599e45f8549a4b SHA512 86c0e7cdaf84b70078ab1c7db89e710ea20876952cfa726507e50d739aadcdf892bb1545bbc5fe1bf861bfbcd829e6414ee54dd9020763db9fd43617b7431532
DIST stockfish-15.tar.gz 189578 BLAKE2B 49af86be2d926ad51021edc119fee260d54fbb37d22d9e0883c382a60d6d0f742b7eee5df296b1dc85552e24269e97c172df70e0a894b328e5bfa92d0614d608 SHA512 d79f713654d5ff0b7f158394c887dce015ef613242e52ef55575c024255da6f6a6bdfe974ff1037599fc99ddfdc2774e37bbc6b8fc88ed0df59590f820a27ffa
+DIST stockfish-16-nn-5af11540bbfe.nnue 40119326 BLAKE2B dc1bf038317c696ba7423d527dc039a077b6008ef6c721afa2084e48b69acb1f3cfde6e0d4861cb29bf8b1cbf693481432f2e0bc376d786c9d6dbb80248883bd SHA512 e86633e1129a5e9727d137ddddba44918bb4dfb88b192659e2323ae4eafc44175c1e9c24ab1ce72dc2a05682b00bdf6aba1f1caf6b0b44ec1cef4a14ae465006
+DIST stockfish-16.tar.gz 195462 BLAKE2B 0f2a55baae13a9abd682672dd88aebcfcd66e4bf6cf1d0886eba48ff331e9aa853bd44fab74c6dbb8a1db4873bf8fe9f98b33ab713878d071950095bd3c0ba82 SHA512 cc8728bd76cb71ab2e3dddb909acf3ebd26a7d44130509dcb2cd90959c939d7324abebf2c69092230028333428a90fa345a10fcb4e9c50e53f4958c61daedcc7
diff --git a/games-board/stockfish/stockfish-16.ebuild b/games-board/stockfish/stockfish-16.ebuild
new file mode 100644
index 000000000000..4535c43cd2b9
--- /dev/null
+++ b/games-board/stockfish/stockfish-16.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Free UCI chess engine, claimed to be the strongest in the world"
+HOMEPAGE="https://stockfishchess.org/"
+
+NNUE_FILE="nn-5af11540bbfe.nnue"
+
+SRC_URI="https://github.com/official-stockfish/Stockfish/archive/sf_${PV}.tar.gz -> ${P}.tar.gz
+ https://tests.stockfishchess.org/api/nn/${NNUE_FILE} -> ${P}-${NNUE_FILE}"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="cpu_flags_arm_v7 cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse debug
+ general-32 general-64 +optimize"
+
+DEPEND="|| ( app-arch/unzip app-arch/zip )"
+RDEPEND=""
+
+S="${WORKDIR}/Stockfish-sf_${PV}/src"
+
+src_prepare() {
+ default
+
+ # remove config sanity check that doesn't like our COMPILER settings
+ sed -i -e 's/ config-sanity//g' Makefile || die
+
+ cp "${DISTDIR}"/${P}-${NNUE_FILE} ${NNUE_FILE} || die "copying the nnue file failed"
+
+ # prevent pre-stripping
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile \
+ || die 'failed to disable stripping in the Makefile'
+
+ # Makefile is a bit optimistic
+ sed -e 's:-flto=full:-flto:g' -i Makefile || die
+}
+
+src_compile() {
+ local my_arch
+
+ # generic unoptimized first
+ use general-32 && my_arch=general-32
+ use general-64 && my_arch=general-64
+
+ # x86
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+
+ # amd64
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+
+ # both bmi2 and avx2 are part of hni (haswell new instructions)
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ # other architectures
+ use cpu_flags_arm_v7 && my_arch=armv7
+ use ppc && my_arch=ppc
+ use ppc64 && my_arch=ppc64
+
+ # There's a nice hack in the Makefile that overrides the value of CXX with
+ # COMPILER to support Travis CI and we abuse it to make sure that we
+ # build with our compiler of choice.
+ emake profile-build ARCH="${my_arch}" \
+ COMP="$(tc-getCXX)" \
+ COMPILER="$(tc-getCXX)" \
+ debug=$(usex debug "yes" "no") \
+ optimize=$(usex optimize "yes" "no")
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc ../AUTHORS ../README.md
+}