summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-28 03:23:22 +0000
committerSam James <sam@gentoo.org>2023-01-28 03:23:22 +0000
commit39f99ad9abd0fc14c6293939003c9bc959479215 (patch)
tree4e860446b68a1a082e697da9cd15ab74a7757fda
parentsys-libs/tdb: add 1.4.8 (diff)
downloadgentoo-39f99ad9abd0fc14c6293939003c9bc959479215.tar.gz
gentoo-39f99ad9abd0fc14c6293939003c9bc959479215.tar.bz2
gentoo-39f99ad9abd0fc14c6293939003c9bc959479215.zip
app-text/msort: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/msort/files/msort-8.53-configure-clang16.patch18
-rw-r--r--app-text/msort/msort-8.53-r2.ebuild (renamed from app-text/msort/msort-8.53-r1.ebuild)5
2 files changed, 21 insertions, 2 deletions
diff --git a/app-text/msort/files/msort-8.53-configure-clang16.patch b/app-text/msort/files/msort-8.53-configure-clang16.patch
new file mode 100644
index 000000000000..de19a029caa4
--- /dev/null
+++ b/app-text/msort/files/msort-8.53-configure-clang16.patch
@@ -0,0 +1,18 @@
+https://src.fedoraproject.org/rpms/msort/blob/addd4dfbb265c79e76f3329c691639d3cf837cb4/f/msort-configure-c99.patch
+
+Include <stdio.h> for the printf function. This avoids a check
+failure with future compilers which do not support implicit function
+declarations.
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,7 +18,7 @@ AC_DEFUN([AC_C_LONG_LONG],
+ ])
+
+ AC_DEFUN([AC_C_PRINTF_THSEP],
+-[AC_TRY_COMPILE(,[printf("%'2d",101);],ac_cv_c_printf_thsep=yes,ac_cv_c_printf_thsep=no)
++[AC_TRY_COMPILE([#include <stdio.h>],[printf("%'2d",101);],ac_cv_c_printf_thsep=yes,ac_cv_c_printf_thsep=no)
+ if test $ac_cv_c_printf_thsep = yes; then
+ AC_DEFINE(HAVE_PRINTF_THSEP, 1, [compiler understands printf flag for thousands separation in ints])
+ fi
+
diff --git a/app-text/msort/msort-8.53-r1.ebuild b/app-text/msort/msort-8.53-r2.ebuild
index 7165b1210a09..39dfa9ff4a68 100644
--- a/app-text/msort/msort-8.53-r1.ebuild
+++ b/app-text/msort/msort-8.53-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,7 +26,8 @@ PATCHES=(
"${FILESDIR}/${P}-fix-missing-limits-header.patch"
"${FILESDIR}/${P}-fix-segfault-on-certain-input.patch"
"${FILESDIR}/${P}-respect-users-cflags.patch"
- )
+ "${FILESDIR}/${P}-configure-clang16.patch"
+)
src_prepare() {
default