summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-13 05:33:03 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-13 05:38:09 +0100
commit3ac147c8b4090debc4f8a2e5d2a3960aac305fd9 (patch)
tree24192670d42585db2c70b4f1b6f16aa843107043
parentdev-python/django-js-asset: Remove old (diff)
downloadgentoo-3ac147c8b4090debc4f8a2e5d2a3960aac305fd9.tar.gz
gentoo-3ac147c8b4090debc4f8a2e5d2a3960aac305fd9.tar.bz2
gentoo-3ac147c8b4090debc4f8a2e5d2a3960aac305fd9.zip
dev-python/google-auth-oauthlib: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index 0239e1ee653c..d1af0c8dddd4 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-library-python-oauthlib-1.0.0.gh.tar.gz 71294 BLAKE2B f0f085ffbec620106f5e7ead56085cee4642932a0fea1bfeec01d1f3b77a8d97aa4e6cdbc29c303abebb30e1994de86cfbb6a950bb34fc243dd312b251afc5da SHA512 74eef43e4ce8de55170c7362eaddcd796c683b3d361d52ff02db1f74b301f12e57f0acb2b52fcc5a6e661b47e3066a780915955b8d933314646483b43c8c5b68
DIST google-auth-library-python-oauthlib-1.1.0.gh.tar.gz 71790 BLAKE2B 0d30bcb076c53052ef1a5d75276266bbbd08940953589b73c370ce66f7f20f4b47d27be8f39bfcfcd109dc7c9e7c39ddfebc65aef4953f168493ad3decdd87dd SHA512 43cd5034ed73b6509861a85abe4090f03499a98de7d88a88adf976fb33e813d31fac067ce25257b540ef71794b0d6faf7dea3c9125c0ae4468a9b2b1ba7994c4
+DIST google-auth-library-python-oauthlib-1.2.0.gh.tar.gz 72990 BLAKE2B 28b828a2a6b4de9deda8eef08f6780cd6f8d3a4df2f63d31c76b72afca12233d79edae46300d773301f7e9d6374e9dbcb5a89b59049a5c01ea5a84ac92285b82 SHA512 2f77d35f76ec12bfdc72dafe9cb33d23c2713985140930766a75377231dc94c32ffa84161251b23244dcf76fe71384421a5d6d8ae11a84b3876d35b5ba393f5a
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild
new file mode 100644
index 000000000000..395c2d95e16a
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest