summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-23 12:16:39 +0100
committerSam James <sam@gentoo.org>2024-04-23 13:41:44 +0100
commit3adaac9a6baaea72b2d82afec290967f0f422a94 (patch)
tree745f1d1a4cca371faa7ea60fbb396edbec996d4c
parentmail-client/thunderbird: enable py3.12 (diff)
downloadgentoo-3adaac9a6baaea72b2d82afec290967f0f422a94.tar.gz
gentoo-3adaac9a6baaea72b2d82afec290967f0f422a94.tar.bz2
gentoo-3adaac9a6baaea72b2d82afec290967f0f422a94.zip
dev-util/schroot: fix build w/ boost-1.85.0
I haven't sent a PR upstream as our last few are rotting. Closes: https://bugs.gentoo.org/930499 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/schroot/files/schroot-1.16.13_p2-boost-1.85.0.patch32
-rw-r--r--dev-util/schroot/schroot-1.6.13_p2-r1.ebuild2
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/schroot/files/schroot-1.16.13_p2-boost-1.85.0.patch b/dev-util/schroot/files/schroot-1.16.13_p2-boost-1.85.0.patch
new file mode 100644
index 000000000000..ba3c10edc104
--- /dev/null
+++ b/dev-util/schroot/files/schroot-1.16.13_p2-boost-1.85.0.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/930499
+--- a/sbuild/sbuild-chroot-config.cc
++++ b/sbuild/sbuild-chroot-config.cc
+@@ -31,6 +31,7 @@
+ #include <cstdlib>
+ #include <cstring>
+
++#include <boost/filesystem/directory.hpp>
+ #include <boost/filesystem/operations.hpp>
+
+ #include <sys/types.h>
+--- a/sbuild/sbuild-run-parts.cc
++++ b/sbuild/sbuild-run-parts.cc
+@@ -29,6 +29,7 @@
+ #include <syslog.h>
+
+ #include <boost/format.hpp>
++#include <boost/filesystem/directory.hpp>
+ #include <boost/filesystem/operations.hpp>
+
+ using boost::format;
+--- a/sbuild/sbuild-util.cc
++++ b/sbuild/sbuild-util.cc
+@@ -35,8 +35,6 @@
+ #include <time.h>
+ #endif
+
+-#include <boost/filesystem/convenience.hpp>
+-
+ using namespace sbuild;
+
+ namespace
diff --git a/dev-util/schroot/schroot-1.6.13_p2-r1.ebuild b/dev-util/schroot/schroot-1.6.13_p2-r1.ebuild
index c287d0c0414d..d4c606a396ec 100644
--- a/dev-util/schroot/schroot-1.6.13_p2-r1.ebuild
+++ b/dev-util/schroot/schroot-1.6.13_p2-r1.ebuild
@@ -53,6 +53,8 @@ PATCHES=(
# https://codeberg.org/shelter/reschroot/pulls/6
"${FILESDIR}"/${PN}-1.6.13-resize-reserve.patch
+
+ "${FILESDIR}"/${PN}-1.16.13_p2-boost-1.85.0.patch
)
src_unpack() {