summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-02 20:33:25 +0100
committerSam James <sam@gentoo.org>2022-10-03 01:38:08 +0100
commit3b16b5c4b1f3c7ff642c408239d9bca6b88bd5fa (patch)
treec681dee02d472cd10350ab8d5cc3ccf56e2aba87
parentdev-libs/atk: Version bump to 2.46.0 (diff)
downloadgentoo-3b16b5c4b1f3c7ff642c408239d9bca6b88bd5fa.tar.gz
gentoo-3b16b5c4b1f3c7ff642c408239d9bca6b88bd5fa.tar.bz2
gentoo-3b16b5c4b1f3c7ff642c408239d9bca6b88bd5fa.zip
games-mud/tf: fix implicit function decls. (Clang 16+)
There's other code quality issues but there's so many of these bugs that we need to just keep moving forward for now, e.g. ``` * socket.c:2657:27: warning: assignment to ‘String *’ from incompatible pointer type ‘conString *’ [-Wincompatible-pointer-types] ``` Closes: https://bugs.gentoo.org/871084 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-mud/tf/files/tf-5.0_beta8_p8-Fix-implicit-function-declarations.patch26
-rw-r--r--games-mud/tf/tf-5.0_beta8_p8-r1.ebuild (renamed from games-mud/tf/tf-5.0_beta8_p8.ebuild)3
2 files changed, 28 insertions, 1 deletions
diff --git a/games-mud/tf/files/tf-5.0_beta8_p8-Fix-implicit-function-declarations.patch b/games-mud/tf/files/tf-5.0_beta8_p8-Fix-implicit-function-declarations.patch
new file mode 100644
index 000000000000..a8ff73a84201
--- /dev/null
+++ b/games-mud/tf/files/tf-5.0_beta8_p8-Fix-implicit-function-declarations.patch
@@ -0,0 +1,26 @@
+From f0cf80b3034c4cad66608ddcec0709b3761adbfc Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 2 Oct 2022 20:31:30 +0100
+Subject: [PATCH] Fix implicit function declarations
+
+Bug: https://bugs.gentoo.org/871084
+--- a/src/malloc.h
++++ b/src/malloc.h
+@@ -34,6 +34,7 @@ extern int low_memory_warning;
+ # define realloc(ptr, size) mrealloc(NULL, ptr, size)
+ # define free(ptr) mfree(NULL, ptr)
+ #else
++# include <stdlib.h>
+ # define mmalloc(md, size) malloc(size)
+ # define mcalloc(md, size) calloc(size)
+ # define mrealloc(md, ptr, size) realloc(ptr, size)
+--- a/src/tfio.c
++++ b/src/tfio.c
+@@ -46,6 +46,7 @@ static const char RCSid[] = "$Id: tfio.c,v 35004.114 2007/01/13 23:12:39 kkeys E
+ #include "keyboard.h" /* keyboard_pos */
+ #include "expand.h" /* current_command */
+ #include "cmdlist.h"
++#include "socket.h"
+
+ TFILE *loadfile = NULL; /* currently /load'ing file */
+ int loadline = 0; /* line number in /load'ing file */
diff --git a/games-mud/tf/tf-5.0_beta8_p8.ebuild b/games-mud/tf/tf-5.0_beta8_p8-r1.ebuild
index 626bfecdddd9..753307b19424 100644
--- a/games-mud/tf/tf-5.0_beta8_p8.ebuild
+++ b/games-mud/tf/tf-5.0_beta8_p8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,6 +37,7 @@ PATCHES=(
"${DISTDIR}"/tf-allrootpatch.txt
"${DISTDIR}"/tf-allsrcpatch.txt
"${FILESDIR}"/tf-50_beta8-pcre.patch
+ "${FILESDIR}"/tf-5.0_beta8_p8-Fix-implicit-function-declarations.patch
)
src_configure() {