summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-06 15:59:05 +0000
committerSam James <sam@gentoo.org>2023-12-06 16:00:58 +0000
commit3c6244c59141bcdd5144430a42b87ab90cea2f19 (patch)
tree51690001453b95783ae3b979a1406986e839a5c3
parentnet-misc/radvd: drop 2.19-r2, 2.19-r4 (diff)
downloadgentoo-3c6244c59141bcdd5144430a42b87ab90cea2f19.tar.gz
gentoo-3c6244c59141bcdd5144430a42b87ab90cea2f19.tar.bz2
gentoo-3c6244c59141bcdd5144430a42b87ab90cea2f19.zip
dev-libs/cdk: build with --enable-const
I don't understand why, in the year 2023, this is optional or at the very least not default-on, but whatever. It turns out that Fedora and openSUSE at least, probably many others, are building cdk with --enable-const which is why this only showed up on Gentoo. We do the same --enable-const dance for ncurses so I suppose I should've known. Enable it for parity given it should be fine to go in this direction anyway. Bug: https://github.com/gphoto/gphoto2/issues/615 Closes: https://bugs.gentoo.org/919279 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/cdk/cdk-5.0.20230201-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-libs/cdk/cdk-5.0.20230201-r1.ebuild b/dev-libs/cdk/cdk-5.0.20230201-r1.ebuild
new file mode 100644
index 000000000000..3faa9c0c03f7
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20230201-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}-$(ver_rs 2 -)"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/thomasdickey.asc
+inherit verify-sig
+
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="https://dickey.his.com/cdk/cdk.html https://github.com/ThomasDickey/cdk-snapshots"
+SRC_URI="https://invisible-island.net/archives/${PN}/${MY_P}.tgz"
+SRC_URI+=" verify-sig? ( https://invisible-island.net/archives/${PN}/${MY_P}.tgz.asc )"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples unicode"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)?]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-thomasdickey )
+"
+
+src_configure() {
+ if [[ ${CHOST} == *-*-darwin* ]] ; then
+ export ac_cv_prog_LIBTOOL=glibtool
+ fi
+
+ # --with-libtool dropped for now because of broken Makefile
+ # bug #790773
+ #
+ # Fedora and openSUSE at least both build with --enable-const. Without
+ # this, consumers end up broken like gphoto2 in bug #919279.
+ econf \
+ --disable-rpath-hack \
+ --enable-const \
+ --with-shared \
+ --with-pkg-config \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${D}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" \
+ install
+
+ if use examples ; then
+ local x
+ for x in include c++ demos examples cli cli/utils cli/samples ; do
+ docinto ${x}
+ find ${x} -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc || die
+ done
+ fi
+
+ find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete || die
+}