summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-10 12:24:49 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-11 17:32:47 +0200
commit3ca448f5c3f8cb5826ae023a1d8b11f844b16ab7 (patch)
treed48b2b62160892f6688dc650df134d145fb18225
parentapp-misc/pip3line: [QA] Add missing PYTHON_REQUIRED_USE (diff)
downloadgentoo-3ca448f5c3f8cb5826ae023a1d8b11f844b16ab7.tar.gz
gentoo-3ca448f5c3f8cb5826ae023a1d8b11f844b16ab7.tar.bz2
gentoo-3ca448f5c3f8cb5826ae023a1d8b11f844b16ab7.zip
dev-python/pysolr: Bump to 3.8.1, enable tests
Closes: https://bugs.gentoo.org/591128 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pysolr/Manifest2
-rw-r--r--dev-python/pysolr/pysolr-3.8.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pysolr/Manifest b/dev-python/pysolr/Manifest
index d67ecbb77b42..f47f34d1b4ec 100644
--- a/dev-python/pysolr/Manifest
+++ b/dev-python/pysolr/Manifest
@@ -1,2 +1,4 @@
DIST pysolr-3.3.2.tar.gz 14193 BLAKE2B 855adfa730a05facdd1a0aab529f7e52a3c052c2b558195616267704691bf91b3b70a123604063c1b818574046cd6d412affc0fe1dc5d43890ea2ca52d8a41e6 SHA512 7252efc42987bdf999d122404e63e6410d2efe7b1a49d378c8ad16c9171d8f26cd5ecd891a8a9daa205333b914ec4f95af105fe1bee25312aa05bb884811aebb
DIST pysolr-3.6.0.tar.gz 28485 BLAKE2B 3994f1586a16ab8a65013d7412c71581448f15356db077f39b87ba780606d508702e0650b9165b96d2bb2064ba4c03d9dd715bcf1f8e802a18bc19ab3aea69f6 SHA512 15d2599bdfe5b364d0c0497f3125945c8a14a61baca6d32bb775d32fac8a8c2bb9ae46e90e4a08ba144e5f6cc83efba7e456ff7ff617c9af34116432bafbac36
+DIST pysolr-3.8.1.tar.gz 46775 BLAKE2B 978869ec1e65699f61c2c33ebe1448c020aec0dee8e65780727a455e25058be6bb0ab7b5d44559d361df09cf338c0dd8b8db164273dc77da2348b6f5118b9c87 SHA512 34489f32cdcbcb7e8109d6d94339fcb200b1367a188a0b9fedf587a77cd64412570b3a796a4da4e0abe6fa3e443a401c4dc0e4946bdc437dd810fee7eabd54a4
+DIST solr-4.10.4.tgz 150059757 BLAKE2B e0f74016b6a92b4c10538ce816b566c17dbf0f7e68a7f1209bb477a2dcf06153da86bbb86d6ceeabda93d79a8c0595e4c96d873fdca8f0baee5fd58890c84da1 SHA512 f7a83504e0f9a4c81b0acafdf452c0c05fcbdf185375f383450bef4fd478812b5259705b55203460d03da46add12cec2442d399ad3716e4e11c393a9a9a01b03
diff --git a/dev-python/pysolr/pysolr-3.8.1.ebuild b/dev-python/pysolr/pysolr-3.8.1.ebuild
new file mode 100644
index 000000000000..6f727c05e826
--- /dev/null
+++ b/dev-python/pysolr/pysolr-3.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+SOLR_PV=4.10.4
+DESCRIPTION="Lightweight python wrapper for Apache Solr"
+HOMEPAGE="https://pypi.org/project/pysolr/ https://github.com/toastdriven/pysolr/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( https://archive.apache.org/dist/lucene/solr/${SOLR_PV}/solr-${SOLR_PV}.tgz )"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/kazoo[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ net-misc/curl
+ virtual/jre:*
+ $(python_gen_cond_dep '
+ dev-python/faulthandler[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ' -2)
+ )"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+}
+
+src_prepare() {
+ # utf8 breaks py2.7 for us
+ sed -i -e 's/…/.../' run-tests.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ if use test; then
+ mkdir -p "${HOME}/download-cache" || die
+ cp "${DISTDIR}/solr-${SOLR_PV}.tgz" "${HOME}/download-cache" || die
+ fi
+}
+
+python_test() {
+ "${EPYTHON}" run-tests.py -v || die "Tests fail with ${EPYTHON}"
+}