summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2023-08-28 10:32:03 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-08-29 13:08:36 +0300
commit3e1eb910497ba0fca83c9a9a1200a9d2ebcf6c14 (patch)
tree7b024a7f7edd266449b0fe3ac1a1ea5167557db4
parentapp-dict/aspell-pl Bump version of the dict file. (diff)
downloadgentoo-3e1eb910497ba0fca83c9a9a1200a9d2ebcf6c14.tar.gz
gentoo-3e1eb910497ba0fca83c9a9a1200a9d2ebcf6c14.tar.bz2
gentoo-3e1eb910497ba0fca83c9a9a1200a9d2ebcf6c14.zip
sys-cluster/glusterfs: rev bump to 11.0-r2
Includes patch for bashcompletion. Fixes python related QA issues. Avoids environment variable (and assists my unused files script for false positives in files/). Closes: https://bugs.gentoo.org/913125 Closes: https://bugs.gentoo.org/913126 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/32483 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-cluster/glusterfs/files/glusterfs-11.0-extras-defer-invoking-of-gluster-volume-set-help-as-.patch85
-rw-r--r--sys-cluster/glusterfs/glusterfs-11.0-r2.ebuild216
2 files changed, 301 insertions, 0 deletions
diff --git a/sys-cluster/glusterfs/files/glusterfs-11.0-extras-defer-invoking-of-gluster-volume-set-help-as-.patch b/sys-cluster/glusterfs/files/glusterfs-11.0-extras-defer-invoking-of-gluster-volume-set-help-as-.patch
new file mode 100644
index 000000000000..f3eacb3a823d
--- /dev/null
+++ b/sys-cluster/glusterfs/files/glusterfs-11.0-extras-defer-invoking-of-gluster-volume-set-help-as-.patch
@@ -0,0 +1,85 @@
+From 26126dd1467fc40af372b9f2ba6ab167e5b9f309 Mon Sep 17 00:00:00 2001
+From: Jaco Kroon <jaco@uls.co.za>
+Date: Mon, 28 Aug 2023 09:54:47 +0200
+Subject: [PATCH] extras: defer invoking of gluster volume set help as late as
+ we can.
+
+---
+ extras/command-completion/gluster.bash | 44 +++++++++++++++++++-------
+ 1 file changed, 32 insertions(+), 12 deletions(-)
+
+diff --git a/extras/command-completion/gluster.bash b/extras/command-completion/gluster.bash
+index 70f8e19558..a096b62890 100644
+--- a/extras/command-completion/gluster.bash
++++ b/extras/command-completion/gluster.bash
+@@ -1,15 +1,5 @@
+ #!/bin/bash
+
+-if pidof glusterd > /dev/null 2>&1; then
+- GLUSTER_SET_OPTIONS="
+- $(for token in `gluster volume set help 2>/dev/null | grep "^Option:" | cut -d ' ' -f 2`
+- do
+- echo "{$token},"
+- done)
+- "
+- GLUSTER_RESET_OPTIONS="$GLUSTER_SET_OPTIONS"
+-fi
+-
+ GLUSTER_TOP_SUBOPTIONS1="
+ {nfs},
+ {brick},
+@@ -161,12 +151,14 @@ GLUSTER_VOLUME_OPTIONS="
+ },
+ {reset
+ {__VOLNAME
+- [ $GLUSTER_RESET_OPTIONS ]
++ {__VOLOPTIONS
++ },
+ }
+ },
+ {set
+ {__VOLNAME
+- [ $GLUSTER_SET_OPTIONS ]
++ {__VOLOPTIONS
++ },
+ }
+ },
+ {start
+@@ -280,6 +272,34 @@ __VOLNAME ()
+ return 0
+ }
+
++__VOLOPTIONS()
++{
++ local zero=0
++ local ret=0
++ local cur_word="$2"
++ local list=""
++
++ if [ "X$1" == "X" ]; then
++ return
++
++ elif [ "$1" == "match" ]; then
++ return 0
++
++ elif [ "$1" == "complete" ]; then
++ if ! pidof glusterd > /dev/null 2>&1; then
++ list='';
++ else
++ list=`gluster volume set help 2>/dev/null | grep "^Option:" | cut -d ' ' -f 2`
++ fi
++ else
++ return 0
++ fi
++
++ func_return=`echo $(compgen -W "$list" -- $cur_word)`
++
++ return 0
++}
++
+ _gluster_throw () {
+ #echo $1 >&2
+ COMPREPLY=''
+--
+2.41.0
+
diff --git a/sys-cluster/glusterfs/glusterfs-11.0-r2.ebuild b/sys-cluster/glusterfs/glusterfs-11.0-r2.ebuild
new file mode 100644
index 000000000000..5500c9af30b3
--- /dev/null
+++ b/sys-cluster/glusterfs/glusterfs-11.0-r2.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit autotools elisp-common python-single-r1 tmpfiles systemd bash-completion-r1
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/ https://github.com/gluster/glusterfs/"
+SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0/${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE="debug emacs +fuse georeplication ipv6 +libtirpc rsyslog selinux static-libs tcmalloc test +uring xml"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ georeplication? ( xml )
+ ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-11.0-fix-crash.patch"
+ "${FILESDIR}/${PN}-11.0-extras-defer-invoking-of-gluster-volume-set-help-as-.patch"
+)
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="
+ acct-group/gluster
+ acct-user/gluster
+ dev-libs/libaio
+ dev-libs/openssl:=[-bindist(-)]
+ net-libs/rpcsvc-proto
+ dev-libs/userspace-rcu:=
+ sys-apps/util-linux
+ sys-libs/readline:=
+ ${PYTHON_DEPS}
+
+ !elibc_glibc? ( sys-libs/argp-standalone )
+ emacs? ( >=app-editors/emacs-23.1:* )
+ fuse? ( >=sys-fs/fuse-2.7.0:0 )
+ libtirpc? ( net-libs/libtirpc:= )
+ !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+ selinux? ( sec-policy/selinux-glusterfs )
+ tcmalloc? ( dev-util/google-perftools )
+ uring? ( sys-libs/liburing:= )
+ xml? ( dev-libs/libxml2 )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/acl
+ test? (
+ >=dev-util/cmocka-1.0.1
+ app-benchmarks/dbench
+ dev-libs/xxhash
+ dev-vcs/git
+ virtual/perl-Test-Harness
+ dev-libs/yajl
+ sys-fs/xfsprogs
+ sys-apps/attr
+ )
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+# if the argp.h header is found in the system. Which should be the case with
+# glibc or if argp-standalone is installed.
+
+pkg_setup() {
+ python_setup "python3*"
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # build rpc-transport and xlators only once as shared libs
+ find rpc/rpc-transport xlators -name Makefile.am -exec \
+ sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' {} + || die
+
+ # fix execution permissions
+ chmod +x libglusterfs/src/gen-defaults.py || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ YACC=yacc.bison \
+ LEX=flex \
+ --disable-fusermount \
+ --disable-lto \
+ $(use_enable debug) \
+ $(use_enable fuse fuse-client) \
+ $(use_enable georeplication) \
+ $(use_enable static-libs static) \
+ $(use_enable test cmocka) \
+ $(use_enable uring linux-io-uring) \
+ $(use_enable xml xml-output) \
+ $(usex ipv6 --with-ipv6-default "") \
+ $(usex libtirpc "" --without-libtirpc) \
+ $(usex tcmalloc "" --without-tcmalloc) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_test() {
+ ./run-tests.sh || die
+}
+
+src_install() {
+ default
+
+ # Path changes based on whether app-shells/bash-completion is installed, bug #911523
+ rm -rf "${ED}"/etc/bash_completion.d "${D}$(get_bashcompdir)" || die
+ newbashcomp extras/command-completion/gluster.bash gluster
+
+ rm \
+ "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+ "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+ "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+ if use rsyslog ; then
+ insinto /etc/rsyslog.d
+ newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+ fi
+
+ if use emacs ; then
+ elisp-install ${PN} extras/glusterfs-mode.el*
+ elisp-site-file-install "50${PN}-mode-gentoo.el"
+
+ fi
+
+ insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+
+ # insert some other tools which might be useful
+ insinto /usr/share/glusterfs/scripts
+ doins \
+ extras/backend-{cleanup,xattr-sanitize}.sh \
+ extras/clear_xattrs.sh \
+ extras/migrate-unify-to-distribute.sh
+
+ # correct permissions on installed scripts
+ # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+ chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+ newinitd "${FILESDIR}/glusterfsd-10.2.initd" glusterfsd
+ newinitd "${FILESDIR}/glusterd-10.2-r2.initd" glusterd
+ newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+ keepdir /var/log/${PN}
+ keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+ systemd_dounit extras/systemd/{glusterd,glustereventsd,glusterfssharedstorage,gluster-ta-volume}.service
+
+ # QA
+ rm -r "${ED}/var/run/" || die
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -delete || die
+ fi
+
+ python_fix_shebang "${ED}"
+ python_optimize
+}
+
+pkg_postinst() {
+ tmpfiles_process gluster.conf
+
+ elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+ elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+ elog " /etc/init.d/glusterd start"
+ echo
+ elog "For static configurations, the glusterfsd startup script can be multiplexed."
+ elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+ elog "separate service. To create additional instances of the glusterfsd service"
+ elog "simply create a symlink to the glusterfsd startup script."
+ echo
+ elog "Example:"
+ elog " # ln -s glusterfsd /etc/init.d/glusterfsd2"
+ elog " # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+ elog "You can now treat glusterfsd2 like any other service"
+ echo
+ ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+ ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+ ewarn "run GlusterFS."
+ echo
+ elog "If you are upgrading from a previous version of ${PN}, please read:"
+ elog " http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}