summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-20 23:09:17 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-20 23:12:03 +0200
commit3fb398627916e52d50782f9e2d37b6ac11c1048e (patch)
treec0bedcf257081569f9f80329f55af1392b6ace10
parentdev-python/logilab-constraint: Remove last-rited pkg (diff)
downloadgentoo-3fb398627916e52d50782f9e2d37b6ac11c1048e.tar.gz
gentoo-3fb398627916e52d50782f9e2d37b6ac11c1048e.tar.bz2
gentoo-3fb398627916e52d50782f9e2d37b6ac11c1048e.zip
dev-python/astng: Remove last-rited pkg
Closes: https://bugs.gentoo.org/666152 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/astng/Manifest1
-rw-r--r--dev-python/astng/astng-0.24.3-r1.ebuild51
-rw-r--r--dev-python/astng/astng-0.24.3.ebuild45
-rw-r--r--dev-python/astng/files/pypy-test.patch36
-rw-r--r--dev-python/astng/metadata.xml22
-rw-r--r--profiles/package.mask1
6 files changed, 0 insertions, 156 deletions
diff --git a/dev-python/astng/Manifest b/dev-python/astng/Manifest
deleted file mode 100644
index 3f204f835d93..000000000000
--- a/dev-python/astng/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST logilab-astng-0.24.3.tar.gz 106660 BLAKE2B 0f82787fc0a3de025fb2921d0e94ca8e2ee33dfe636c9ad55f6494983467c8acfdab0aa83e7f84f1525697a6a5317569ff51537732a90ccdec2646f380b316ac SHA512 fb1e46ebf7111d727cd9d187968cb349dc23dfba0d4d8c6c793a8c081d4506f11e488074cc51b632c525aa264cfa50279dda90f0cf35dc2120ebbf4714902525
diff --git a/dev-python/astng/astng-0.24.3-r1.ebuild b/dev-python/astng/astng-0.24.3-r1.ebuild
deleted file mode 100644
index c082787d9da0..000000000000
--- a/dev-python/astng/astng-0.24.3-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://www.logilab.org/project/logilab-astng https://pypi.org/project/logilab-astng/"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz mirror://pypi/l/logilab-astng/logilab-${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# 1.2.2-r1 for namespace files
-RDEPEND=">=dev-python/logilab-common-1.2.2-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/egenix-mx-base-3.0.0[$(python_gen_usedep 'python2*')] )"
-
-S="${WORKDIR}/logilab-${P}"
-RESTRICT="test" # erroneous failures
-
-# a wit; pypy reports astng modules differently
-PATCHES=( "${FILESDIR}"/pypy-test.patch )
-
-python_test() {
- distutils_install_for_testing
- # test target needs unpacked test directories, doesn't like binary egg
- esetup.py install_lib --install-dir="${TEST_DIR}"/lib
- #https://bitbucket.org/logilab/astroid/issue/1/test-suite-fails-in-0243-under-py32-pypy
- # Make sure that the tests use correct modules.
- cd "${TEST_DIR}"/lib || die
- pytest -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- rm "${D}$(python_get_sitedir)/logilab/__init__.py" || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/astng/astng-0.24.3.ebuild b/dev-python/astng/astng-0.24.3.ebuild
deleted file mode 100644
index 4bbd302c3dd6..000000000000
--- a/dev-python/astng/astng-0.24.3.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="https://www.logilab.org/project/logilab-astng https://pypi.org/project/logilab-astng/"
-SRC_URI="ftp://ftp.logilab.org/pub/astng/logilab-${P}.tar.gz mirror://pypi/l/logilab-astng/logilab-${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.59.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/egenix-mx-base-3.0.0[$(python_gen_usedep 'python2*')] )"
-
-S="${WORKDIR}/logilab-${P}"
-RESTRICT="test" # erroneous failures
-
-# a wit; pypy reports astng modules differently
-PATCHES=( "${FILESDIR}"/pypy-test.patch )
-
-python_test() {
- distutils_install_for_testing
- # test target needs unpacked test directories, doesn't like binary egg
- esetup.py install_lib --install-dir="${TEST_DIR}"/lib
- #https://bitbucket.org/logilab/astroid/issue/1/test-suite-fails-in-0243-under-py32-pypy
- # Make sure that the tests use correct modules.
- cd "${TEST_DIR}"/lib || die
- pytest -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
-
- rm "${D}$(python_get_sitedir)/logilab/__init__.py" || die
-}
diff --git a/dev-python/astng/files/pypy-test.patch b/dev-python/astng/files/pypy-test.patch
deleted file mode 100644
index 42cb3864b43b..000000000000
--- a/dev-python/astng/files/pypy-test.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -ur logilab-astng-0.24.3.orig/test/unittest_builder.py logilab-astng-0.24.3/test/unittest_builder.py
---- test/unittest_builder.py 2013-04-17 17:38:31.000000000 +0800
-+++ test/unittest_builder.py 2013-06-19 02:13:51.425269363 +0800
-@@ -62,8 +62,12 @@
- self.assertEqual(name.tolineno, 4)
- strarg = callfunc.args[0]
- self.assertIsInstance(strarg, nodes.Const)
-- self.assertEqual(strarg.fromlineno, 5) # no way for this one (is 4 actually)
-- self.assertEqual(strarg.tolineno, 5)
-+ if hasattr(sys, 'pypy_version_info'):
-+ self.assertEqual(strarg.fromlineno, 4) # no way for this one (is 4 actually)
-+ self.assertEqual(strarg.tolineno, 4)
-+ else:
-+ self.assertEqual(strarg.fromlineno, 5) # no way for this one (is 4 actually)
-+ self.assertEqual(strarg.tolineno, 5)
- namearg = callfunc.args[1]
- self.assertIsInstance(namearg, nodes.Name)
- self.assertEqual(namearg.fromlineno, 5)
-diff -ur logilab-astng-0.24.3.orig/test/unittest_inference.py logilab-astng-0.24.3/test/unittest_inference.py
---- test/unittest_inference.py 2013-04-17 17:38:31.000000000 +0800
-+++ test/unittest_inference.py 2013-06-19 02:52:41.618270007 +0800
-@@ -710,8 +710,12 @@
- node = get_name_node(astng, 'open', -1)
- infered = list(node.infer())
- self.assertEqual(len(infered), 1)
-- self.assertIsInstance(infered[0], nodes.Function)
-- self.assertEqual(infered[0].name, 'open')
-+ if hasattr(sys, 'pypy_version_info'):
-+ self.assertIsInstance(infered[0], nodes.Class)
-+ self.assertEqual(infered[0].name, 'file')
-+ else:
-+ self.assertIsInstance(infered[0], nodes.Function)
-+ self.assertEqual(infered[0].name, 'open')
-
- def test_callfunc_context_func(self):
- code = '''
diff --git a/dev-python/astng/metadata.xml b/dev-python/astng/metadata.xml
deleted file mode 100644
index b7ac41e3d53b..000000000000
--- a/dev-python/astng/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">The aim of this module is to provide a common base representation of
- python source code for projects such as pychecker, pyreverse,
- pylint... Well, actually the development of this library is
- essentially governed by pylint's needs.
- It provides a compatible representation which comes from the _ast
- module. It rebuilds the tree generated by the builtin _ast module by
- recursively walking down the AST and building an extended ast (let's
- call it astng ;). The new node classes have additional methods and
- attributes for different usages. They include some support for static
- inference and local name scopes. Furthermore, astng builds partial
- trees by inspecting living objects.</longdescription>
- <upstream>
- <remote-id type="pypi">logilab-astng</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index a3e6527733e4..0e8745682479 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -160,7 +160,6 @@ dev-python/tinydb
# installable. The only revdep left is app-vim/python-mode where
# the dep looks completely mistaken. Bug #666152.
app-vim/python-mode
-dev-python/astng
# Mike Gilbert <floppym@gentoo.org> (16 Sep 2018)
# Dev channel releases are only for people who are developers or want more