summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-03-03 00:50:36 -0600
committerSam James <sam@gentoo.org>2023-03-04 07:18:10 +0000
commit4107569394f4710e79bd17841c9d2f0f6881e57d (patch)
tree5b2dc91e5860f25c128b456ab792ebf640ac5ef5
parentapp-editors/vim: configure implicit function declarations (diff)
downloadgentoo-4107569394f4710e79bd17841c9d2f0f6881e57d.tar.gz
gentoo-4107569394f4710e79bd17841c9d2f0f6881e57d.tar.bz2
gentoo-4107569394f4710e79bd17841c9d2f0f6881e57d.zip
app-editors/vim-core: configure implicit function declarations
Ignore implicit function declarations for platform-specific functions, `acl()` is for Solaris and `statacl()` is for AIX. Closes: https://bugs.gentoo.org/898406 Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29907 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-9.0.1000.ebuild8
-rw-r--r--app-editors/vim-core/vim-core-9.0.1157.ebuild8
-rw-r--r--app-editors/vim-core/vim-core-9.0.1363.ebuild8
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild8
4 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/vim-core/vim-core-9.0.1000.ebuild b/app-editors/vim-core/vim-core-9.0.1000.ebuild
index 98d156f8fe5e..b67954888b35 100644
--- a/app-editors/vim-core/vim-core-9.0.1000.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.1000.ebuild
@@ -38,6 +38,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898406):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim-core/vim-core-9.0.1157.ebuild b/app-editors/vim-core/vim-core-9.0.1157.ebuild
index f0e509e7c901..0f32efa8165b 100644
--- a/app-editors/vim-core/vim-core-9.0.1157.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.1157.ebuild
@@ -38,6 +38,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898406):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim-core/vim-core-9.0.1363.ebuild b/app-editors/vim-core/vim-core-9.0.1363.ebuild
index 64e63ae0b84e..c2cb2313c925 100644
--- a/app-editors/vim-core/vim-core-9.0.1363.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.1363.ebuild
@@ -38,6 +38,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898406):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 64e63ae0b84e..c2cb2313c925 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -38,6 +38,14 @@ if [[ ${PV} != 9999* ]]; then
)
fi
+# platform-specific checks (bug #898406):
+# - acl() -- Solaris
+# - statacl() -- AIX
+QA_CONFIG_IMPL_DECL_SKIP=(
+ 'acl'
+ 'statacl'
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL