summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 07:12:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 07:56:29 +0200
commit41ab325a6b3a442c257dedb8b8d4c7c984ab89f9 (patch)
treed00b943b0aea6993262e681d853ddd8bd99999d2
parentdev-python/awxkit: Bump to 23.2.0 (diff)
downloadgentoo-41ab325a6b3a442c257dedb8b8d4c7c984ab89f9.tar.gz
gentoo-41ab325a6b3a442c257dedb8b8d4c7c984ab89f9.tar.bz2
gentoo-41ab325a6b3a442c257dedb8b8d4c7c984ab89f9.zip
dev-python/icalendar: Bump to 5.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/icalendar/Manifest1
-rw-r--r--dev-python/icalendar/icalendar-5.0.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/icalendar/Manifest b/dev-python/icalendar/Manifest
index 8254e38d11e1..79f7ce605c83 100644
--- a/dev-python/icalendar/Manifest
+++ b/dev-python/icalendar/Manifest
@@ -1,3 +1,4 @@
+DIST icalendar-5.0.10.tar.gz 108657 BLAKE2B 99d5bd1c58f9413dcc5f0e2c2cabb6ed9bf29a24d3416aac7a56dc4e669012c9b7fab6a59cff2d93cea23b979492bda3a25834f79f97d9f3f562722085f1ab94 SHA512 0d03312d175a152a7c8bf6e574acb216e107eaeae197f2f10a904ce5ef40ecb156433e45ef5c8d3c1553842d1df0440363ed0f8d115337919139b7eae5b82796
DIST icalendar-5.0.7.tar.gz 104099 BLAKE2B df45ee6b8c1ad5bfc558195e86e2456aae8f70613724ba16e74093e5454695d8d4ef2e0eb2e312dd2a94c3a12bc6e4febc21174e8380e249f2de906500a1cfc8 SHA512 c541e61d79b76123d119e51ee6d927795a7d675aded427a21bd38d0f069ea454e182a61ff86b96c7769c42560dfc20f7facb00dfe8a9cfa47da74b279d841b42
DIST icalendar-5.0.8.tar.gz 106954 BLAKE2B 2e6d9cbae1a8feba40c33403e047386dcb8846fb7d8fd9e6b78d2b58ffeb4fb033438f240dd3fa3290f5edeb171a940dc2213cd5d758f59908eea1099807f52d SHA512 275884cf934d8a275dc75346b0518701f2160c43d479e91069f3cad4370b14d9cbc78bf0c1fea287df2da271ec2f71137cfd5ec202d8304df16cf474f7008b53
DIST icalendar-5.0.9.tar.gz 107376 BLAKE2B 506ccdbccc0e9d3e755becfb811380b9fc7c9d401b5812d3c56170c27350311c3d5bd2809e3dd93c1e6e361ce46015f1916326bc306571b1139b9d7aac592eac SHA512 b70c1adbcaeebbd81ba8c4cf4db146d593131dd3ba7c995f3b2417bf871cca82042ec43eab127f158895070d4e17ebf46cb30aca0a33b8344665798c29fd2e27
diff --git a/dev-python/icalendar/icalendar-5.0.10.ebuild b/dev-python/icalendar/icalendar-5.0.10.ebuild
new file mode 100644
index 000000000000..abbe040cb9ee
--- /dev/null
+++ b/dev-python/icalendar/icalendar-5.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Package used for parsing and generating iCalendar files (RFC 2445)"
+HOMEPAGE="
+ https://github.com/collective/icalendar/
+ https://pypi.org/project/icalendar/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # reset conf.py to not read version from an installed instance
+ sed -e "s:pkg_resources.get_distribution('icalendar').version:'${PV}':" \
+ -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}