summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-01-22 15:43:55 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-01-22 15:44:39 +0100
commit42536b527a9dd7c28fb274f5fbd6995f565fde42 (patch)
treed3b4846d1480765c83de1f0bb18772764df385a5
parentdev-python/pysrt: remove old (diff)
downloadgentoo-42536b527a9dd7c28fb274f5fbd6995f565fde42.tar.gz
gentoo-42536b527a9dd7c28fb274f5fbd6995f565fde42.tar.bz2
gentoo-42536b527a9dd7c28fb274f5fbd6995f565fde42.zip
Revert "dev-python/pysrt: remove old"
This reverts commit 75e875c8e9f5de298c8450ad4e7212b27e299e65. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/pysrt/pysrt-1.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pysrt/pysrt-1.1.1.ebuild b/dev-python/pysrt/pysrt-1.1.1.ebuild
new file mode 100644
index 000000000000..315ab0b380ac
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.org/project/pysrt/"
+SRC_URI="https://pypi.python.org/packages/f6/33/16ad65a8973cb8bcb494af09ee1b9ab5ffdd6ff300bce5d3ac7d3cb1f2cc/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[coverage(+),${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}