summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2017-08-15 16:27:46 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2017-08-15 16:35:28 -0700
commit42d27f0e8f26018c3c6962580bd4edfe50f557d8 (patch)
tree895294eec059e705e8633e22cecf8835cd1720ec
parentdev-python/keyring: disable interactive test (diff)
downloadgentoo-42d27f0e8f26018c3c6962580bd4edfe50f557d8.tar.gz
gentoo-42d27f0e8f26018c3c6962580bd4edfe50f557d8.tar.bz2
gentoo-42d27f0e8f26018c3c6962580bd4edfe50f557d8.zip
dev-python/oauth2client: bump, based on patch in bug 626390.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/oauth2client/Manifest1
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oauth2client/Manifest b/dev-python/oauth2client/Manifest
index 7219f557cc7a..62411fb57ee7 100644
--- a/dev-python/oauth2client/Manifest
+++ b/dev-python/oauth2client/Manifest
@@ -2,3 +2,4 @@ DIST oauth2client-1.5.2.tar.gz 131665 SHA256 b8df20b122e4f49a5fe5bc3c825d16015f5
DIST oauth2client-2.0.1.tar.gz 153127 SHA256 fa0357fca4ce431073ead236256347aafe3d368c16c5edaeba7f826b1b1d5fb6 SHA512 66179a604418a8aee9ca9dbfc5ad18356d5130a588e85f4dab3330feef194af2114bc2eb18ec625acf791938e4d7f78ee55284f45a67a48c775676697ce2b183 WHIRLPOOL bef0f7394cbeade328f74288bd602973a7828915ff616c7331d6c1910be02bc74a8e11062bd0602a2c4f1681d7d8c6558aecd695df3ef711f74ba81fad0b1ab3
DIST oauth2client-2.2.0.tar.gz 167484 SHA256 07b44748059d6390ce2247195b2ae2117773617614f76ec9375e56fd43295f06 SHA512 1e23c3f655e955dbf0cdb2b78613768ca4c6eb4336b555e3553da212fd762ba12329584f108d8145810228cf44da018675b38dd152b06e58be4eb18d4f8127c6 WHIRLPOOL 6cb1b3a6dbc4d3e0fca8d72417810873f11428afb4d4f52b08f7028c984bd330acf043ca10c339453c6f4e38c1f179c2e9126a9f6cb419323a53cbc769ebbe8f
DIST oauth2client-4.0.0.tar.gz 183288 SHA256 7230f52f7f1d4566a3f9c3aeb5ffe2ed80302843ce5605853bee1f08098ede46 SHA512 b59805702c7acb306801a04a92b7f700c0f58d5937b4b27a497018d313922512b5ec3f1711bacf13bc7e01c4f006eda5344a9055f981ba34e116c34c56c5dfec WHIRLPOOL 409ff71754038acb3a67841edfb7dd33865c0db9e55717ea2255eab506d298603034cc5347c6219f8978b5a2ec068a5ccf4e1f0ba53533e9810794016e4822b1
+DIST oauth2client-4.1.2.tar.gz 184731 SHA256 77737f8f831a1306b022deb2cf6f3c9dbe4b338b8b9afcf84e7be5bef4d7e833 SHA512 908f0e32f0ef76c3eb86ee34118d4100bc08fa34aa89c561793bf8c55078f07611935ee6aecb6d2ae2f7e96a18ac3bc25af0321fe564f26042ff2bb5eab30b18 WHIRLPOOL ad4a6c6ac7a5e1831a3c2829d6ca445290e34b03134b94def27a45df0ddea0488087aefa6cd5d9fb4bd3e4843eda75eafbe03e587071eaf25e76d55116a67da0
diff --git a/dev-python/oauth2client/oauth2client-4.1.2.ebuild b/dev-python/oauth2client/oauth2client-4.1.2.ebuild
new file mode 100644
index 000000000000..fb86986d3712
--- /dev/null
+++ b/dev-python/oauth2client/oauth2client-4.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
+HOMEPAGE="https://github.com/google/oauth2client"
+SRC_URI="https://github.com/google/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+REQUIRED_USE="|| ( $(python_gen_useflags 'python*') )"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/keyring[${PYTHON_USEDEP}]' 'python*')
+ !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S="${WORKDIR}"/${P/_p/-post}
+
+python_prepare() {
+ # keyring is not fuly supported by pypy yet, because dbus-python can't support pypy
+ # oauth2client -> keyring -> secretstorage -> dbus-python
+ # https://github.com/mitya57/secretstorage/issues/10
+ case $PYTHON in
+ pypy|*pypy|*pypy3|pypy3) \
+ find "${BUILD_DIR}/.." -name '*keyring*py' -delete ;;
+ esac
+}
+
+python_test() {
+ nosetests -e appengine -e django_util -e test_multiprocess_file_storage -e test_bad_positional || die
+ # appengine - requires appengine
+ # django_util - requires django
+ # test_multiprocess_file_storage - requires fasteners
+ # test_bad_positional - expects TypeError, gets ValueError
+}