summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:52:19 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:52:19 +0200
commit43193035f7c468fcd1488df3558fb0d4c4ab38aa (patch)
treeda074c4c88aab6d185254e6477e4af65d89ec939
parentdev-python/waitress: Bump to 1.4.3 (diff)
downloadgentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.tar.gz
gentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.tar.bz2
gentoo-43193035f7c468fcd1488df3558fb0d4c4ab38aa.zip
dev-python/u-msgpack: Bump to 2.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/u-msgpack/Manifest1
-rw-r--r--dev-python/u-msgpack/u-msgpack-2.6.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/u-msgpack/Manifest b/dev-python/u-msgpack/Manifest
index b8ec9d19510f..1e0a66dca73c 100644
--- a/dev-python/u-msgpack/Manifest
+++ b/dev-python/u-msgpack/Manifest
@@ -1 +1,2 @@
DIST u-msgpack-2.5.2.tar.gz 17641 BLAKE2B 643984fd9ed2f87ad0cce9e64aaa064465048067098bf01bd844a04bc1b870d6688eac6bc9f1dddf9bf705fb14bc332796f06b8b59d0dfe79261e85ba11b60d1 SHA512 cefba7ed86d2b7c37b0d92e3a4fb4ec62c89dffee0be078c783010638413e6ce1af7ab959b43dfedb6fd8cf2943185c18fc2201a4a9764c423e8242bcedf21a9
+DIST u-msgpack-2.6.0.tar.gz 19911 BLAKE2B a6599a85fcb386f91dce4d11fd8d10c6be75c1fe4e80756c58058bcb7c2934c2174afe65bc0b88e11c5c9e3f66b46c956c9209bb6faf74ab5c382bd665c412fc SHA512 b0f2fa677001705a8a1e96e590fd334d0561065e0617a56a31abd506907dc2446c93f8c4429e65e86c87f6d2cf3e19a921fa0aaccad5cdaf1acd1ae0a1235688
diff --git a/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild b/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild
new file mode 100644
index 000000000000..3bd4d2b913b0
--- /dev/null
+++ b/dev-python/u-msgpack/u-msgpack-2.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN}-python"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A portable, lightweight MessagePack serializer and deserializer"
+HOMEPAGE="https://github.com/vsergeev/u-msgpack-python https://pypi.org/project/u-msgpack-python/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+distutils_enable_tests pytest