summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:40 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:38 +0100
commit431ac0f848553bf42fe5c3d692a82e5491def72f (patch)
treeca8a67dbb2d9cacf4cf4aa0ffc84a8909ad46343
parentdev-haskell/hashable: add 1.4.2.0-r2 (diff)
downloadgentoo-431ac0f848553bf42fe5c3d692a82e5491def72f.tar.gz
gentoo-431ac0f848553bf42fe5c3d692a82e5491def72f.tar.bz2
gentoo-431ac0f848553bf42fe5c3d692a82e5491def72f.zip
dev-haskell/haskeline: Hackage revision bump
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/haskeline/Manifest1
-rw-r--r--dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild38
-rw-r--r--dev-haskell/haskeline/haskeline-0.8.2.ebuild40
-rw-r--r--dev-haskell/haskeline/metadata.xml9
4 files changed, 40 insertions, 48 deletions
diff --git a/dev-haskell/haskeline/Manifest b/dev-haskell/haskeline/Manifest
index ce4e21193edd..314ae7a6e71a 100644
--- a/dev-haskell/haskeline/Manifest
+++ b/dev-haskell/haskeline/Manifest
@@ -1 +1,2 @@
+DIST haskeline-0.8.2-rev3.cabal 6005 BLAKE2B 33c5f34d92060bef118fd9685cfe26384a1494e1bfe9eff0ed397fcbb00908a19a070d1c3502dd7bcf538f85ffcc56b986170453c3b59a877584bcf9bfd9e629 SHA512 86461b6b5398c42fd4776c60854b0d251a7762b21ef0a65978182b2f4411400352a55773eaa2fecb7aa1fc309554c8d50ff9bf01254c22352a3d384cde92d4c5
DIST haskeline-0.8.2.tar.gz 72759 BLAKE2B 389908d07775bd150801c7423f3cdc860e1330c0f13cd754374870b4aea19d5bd01f761aec7aa0f2effe87a80c25dc8e7f4390c095627c4d25ed2976de855a63 SHA512 5e8dccceb2230340a7f07f2e0926a938b52106d8a1638be6c1a031802ecbdf12cb42246096518ac12614d5d48479666a44ad33e5e32ab0ac2043b630a7b53746
diff --git a/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild b/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..e3c2e948c9c5
--- /dev/null
+++ b/dev-haskell/haskeline/haskeline-0.8.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+#hackport: flags: -examples
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite
+inherit haskell-cabal
+
+DESCRIPTION="A command-line interface for user input, written in Haskell"
+HOMEPAGE="https://github.com/judah/haskeline"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+terminfo"
+
+RESTRICT=test # test requires example executable which does not work correctly
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-examples \
+ $(cabal_flag terminfo terminfo)
+}
+
+CABAL_CORE_LIB_GHC_PV="8.10.6 8.10.7 9.0.2 9.2.4 9.2.5 9.2.6 9.2.7 9.2.8 9.4.4 9.4.5"
diff --git a/dev-haskell/haskeline/haskeline-0.8.2.ebuild b/dev-haskell/haskeline/haskeline-0.8.2.ebuild
deleted file mode 100644
index 1e3a37f5a13e..000000000000
--- a/dev-haskell/haskeline/haskeline-0.8.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.7.9999
-#hackport: flags: -examples
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A command-line interface for user input, written in Haskell"
-HOMEPAGE="https://github.com/judah/haskeline"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-# keep in sync with ghc-8.10.6
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
-IUSE="+terminfo"
-
-RESTRICT=test # test requires example executable which does not work correctly
-
-RDEPEND=">=dev-haskell/exceptions-0.10:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
- >=dev-haskell/stm-2.4:=[profile?] <dev-haskell/stm-2.6:=[profile?]
- >=dev-lang/ghc-8.4.3:=
- terminfo? ( >=dev-haskell/terminfo-0.3.1.3:=[profile?] <dev-haskell/terminfo-0.5:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-examples \
- $(cabal_flag terminfo terminfo)
-}
-
-# ghc-9.0.1 actually comes bundled with haskeline-0.8.1.0
-CABAL_CORE_LIB_GHC_PV="8.10.6 9.0.2"
diff --git a/dev-haskell/haskeline/metadata.xml b/dev-haskell/haskeline/metadata.xml
index 3e0dfe213e4f..0151f4371988 100644
--- a/dev-haskell/haskeline/metadata.xml
+++ b/dev-haskell/haskeline/metadata.xml
@@ -5,18 +5,11 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Haskeline provides a user interface for line input in command-line
- programs. This library is similar in purpose to readline, but since
- it is written in Haskell it is (hopefully) more easily used in other
- Haskell programs.
-
- Haskeline runs both on POSIX-compatible systems and on Windows.
- </longdescription>
<use>
<flag name="terminfo">Use the terminfo package for POSIX consoles.</flag>
</use>
<upstream>
+ <remote-id type="hackage">haskeline</remote-id>
<remote-id type="github">judah/haskeline</remote-id>
</upstream>
</pkgmetadata>