summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-13 12:51:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-13 13:16:26 +0100
commit4427762ff07079ce1c24bcd42acc1956c2aae8a3 (patch)
tree25202218d21cf8c695f379776c261a8ee9657b22
parentnet-vpn/freelan: bump to 2.1 (diff)
downloadgentoo-4427762ff07079ce1c24bcd42acc1956c2aae8a3.tar.gz
gentoo-4427762ff07079ce1c24bcd42acc1956c2aae8a3.tar.bz2
gentoo-4427762ff07079ce1c24bcd42acc1956c2aae8a3.zip
net-vpn/freelan: Remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--net-vpn/freelan/Manifest1
-rw-r--r--net-vpn/freelan/files/boost158.patch41
-rw-r--r--net-vpn/freelan/files/boost163.patch24
-rw-r--r--net-vpn/freelan/files/gcc7.patch60
-rw-r--r--net-vpn/freelan/files/glibc225.patch21
-rw-r--r--net-vpn/freelan/files/mf.patch33
-rw-r--r--net-vpn/freelan/files/prefix.patch81
-rw-r--r--net-vpn/freelan/freelan-2.0.ebuild62
8 files changed, 0 insertions, 323 deletions
diff --git a/net-vpn/freelan/Manifest b/net-vpn/freelan/Manifest
index 5fa81975f8e8..d901ce7acc22 100644
--- a/net-vpn/freelan/Manifest
+++ b/net-vpn/freelan/Manifest
@@ -1,2 +1 @@
-DIST freelan-2.0.tar.gz 4330112 BLAKE2B 2b900f8b04b4eb19334d4a7bac29b024ff59e37d66df533cbc84d346049994e022ffb71eae8b5c418a727bb01fc4bcdc190ffed7c49023df98aa60a2437cf0af SHA512 72e5381fdad4d413f4f85c4789ad78c38360a300da6f49a3e8119fe2cacb7a7b05ce16ddcbfcdc008e1c2848c535648967e92f082338fdfb2c1b8e43f53291cc
DIST freelan-2.1.tar.gz 4340411 BLAKE2B 78365f8f4d6334313abd824a68a06470a34e6e62b17fae1f32e3d655c1210892ccbb17ba81b02930e1554d73adbaea171562365dcda091677513d15506f631fe SHA512 f01f0021ab54450be8cf81b3ee58a74ff02e421ccc0e6b7a3733bbd721dedb14a0bf8c6a9e01d20f000e4b232c89fc358834e696211e239c899e4926e6682e1a
diff --git a/net-vpn/freelan/files/boost158.patch b/net-vpn/freelan/files/boost158.patch
deleted file mode 100644
index 7d5bb740f7bd..000000000000
--- a/net-vpn/freelan/files/boost158.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-commit 68d18a5a7dd7fad8638409d46d144d33a30b54ce
-Author: Mihai Bişog <mihai.bisog@gmail.com>
-Date: Sat Aug 1 15:18:35 2015 +0300
-
- Fixed compilation errors when compiling against boost 1.58
-
-diff --git a/libs/asiotap/include/asiotap/types/endpoint.hpp b/libs/asiotap/include/asiotap/types/endpoint.hpp
-index 125e1b4..318b7e6 100644
---- a/libs/asiotap/include/asiotap/types/endpoint.hpp
-+++ b/libs/asiotap/include/asiotap/types/endpoint.hpp
-@@ -350,6 +350,9 @@ namespace asiotap
- */
- std::istream& operator>>(std::istream& is, endpoint& value);
-
-+// Note: this operator is defined in boost variant as of version 1.58. Keeping it around will
-+// introduce overload resolution ambiguity.
-+#if BOOST_VERSION < 105800
- /**
- * \brief Compare two endpoints.
- * \param lhs The left argument.
-@@ -360,6 +363,7 @@ namespace asiotap
- {
- return !(lhs == rhs);
- }
-+#endif
-
- /**
- * \brief Get an endpoint with a default port.
-diff --git a/libs/freelan/src/curl.cpp b/libs/freelan/src/curl.cpp
-index 342bb79..392d734 100644
---- a/libs/freelan/src/curl.cpp
-+++ b/libs/freelan/src/curl.cpp
-@@ -146,7 +146,7 @@ namespace freelan
-
- void curl::set_proxy(const asiotap::endpoint& proxy)
- {
-- if (proxy != asiotap::hostname_endpoint::null())
-+ if (proxy != asiotap::endpoint(asiotap::hostname_endpoint::null()))
- {
- set_option(CURLOPT_PROXY, static_cast<const void*>(boost::lexical_cast<std::string>(proxy).c_str()));
- }
diff --git a/net-vpn/freelan/files/boost163.patch b/net-vpn/freelan/files/boost163.patch
deleted file mode 100644
index 33636ef0d0b1..000000000000
--- a/net-vpn/freelan/files/boost163.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Index: freelan-2.0/libs/freelan/src/core.cpp
-===================================================================
---- freelan-2.0.orig/libs/freelan/src/core.cpp
-+++ freelan-2.0/libs/freelan/src/core.cpp
-@@ -1766,7 +1766,8 @@ namespace freelan
- {
- m_logger(fscp::log_level::information) << "IPv4 address: " << m_configuration.tap_adapter.ipv4_address_prefix_length;
-
-- tap_config.ipv4.network_address = { m_configuration.tap_adapter.ipv4_address_prefix_length.address(), m_configuration.tap_adapter.ipv4_address_prefix_length.prefix_length() };
-+ asiotap::base_ip_network_address<boost::asio::ip::address_v4> a(m_configuration.tap_adapter.ipv4_address_prefix_length.address(), m_configuration.tap_adapter.ipv4_address_prefix_length.prefix_length());
-+ tap_config.ipv4.network_address = a;
- }
- else
- {
-@@ -1778,7 +1779,8 @@ namespace freelan
- {
- m_logger(fscp::log_level::information) << "IPv6 address: " << m_configuration.tap_adapter.ipv6_address_prefix_length;
-
-- tap_config.ipv6.network_address = { m_configuration.tap_adapter.ipv6_address_prefix_length.address(), m_configuration.tap_adapter.ipv6_address_prefix_length.prefix_length() };
-+ asiotap::base_ip_network_address<boost::asio::ip::address_v6> a(m_configuration.tap_adapter.ipv6_address_prefix_length.address(), m_configuration.tap_adapter.ipv6_address_prefix_length.prefix_length());
-+ tap_config.ipv6.network_address = a;
- }
- else
- {
diff --git a/net-vpn/freelan/files/gcc7.patch b/net-vpn/freelan/files/gcc7.patch
deleted file mode 100644
index 71bcf3d9a841..000000000000
--- a/net-vpn/freelan/files/gcc7.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-commit 5014a8023b42762052d6417ebbc0cd2adb1fda90
-Author: Sebastien Vincent <sebastien.vincent@cppextrem.com>
-Date: Sat Aug 5 20:10:55 2017 +0200
-
- Fixes compilation with g++-7.
-
-diff --git a/libs/asiotap/src/posix/posix_tap_adapter.cpp b/libs/asiotap/src/posix/posix_tap_adapter.cpp
-index 71377cee..cdd7abf3 100644
---- a/libs/asiotap/src/posix/posix_tap_adapter.cpp
-+++ b/libs/asiotap/src/posix/posix_tap_adapter.cpp
-@@ -206,6 +206,7 @@ namespace asiotap
- {
- result[name] = name;
- }
-+ break;
- }
- case tap_adapter_layer::ip:
- {
-@@ -213,6 +214,7 @@ namespace asiotap
- {
- result[name] = name;
- }
-+ break;
- }
- }
- }
-diff --git a/libs/netlinkplus/include/netlinkplus/endpoint.hpp b/libs/netlinkplus/include/netlinkplus/endpoint.hpp
-index 3503cae3..74fb7e1b 100644
---- a/libs/netlinkplus/include/netlinkplus/endpoint.hpp
-+++ b/libs/netlinkplus/include/netlinkplus/endpoint.hpp
-@@ -44,6 +44,8 @@
-
- #pragma once
-
-+#include <cstring>
-+
- #include <boost/asio.hpp>
-
- #include <linux/netlink.h>
-@@ -125,17 +127,17 @@ namespace netlinkplus
-
- friend bool operator==(const netlink_endpoint& lhs, const netlink_endpoint& rhs)
- {
-- return (lhs.m_sockaddr == rhs.m_sockaddr);
-+ return (std::memcmp(&lhs.m_sockaddr, &rhs.m_sockaddr, sizeof(sockaddr_nl)) == 0);
- }
-
- friend bool operator!=(const netlink_endpoint& lhs, const netlink_endpoint& rhs)
- {
-- return (lhs.m_sockaddr != rhs.m_sockaddr);
-+ return (std::memcmp(&lhs.m_sockaddr, &rhs.m_sockaddr, sizeof(sockaddr_nl)) != 0);
- }
-
- friend bool operator<(const netlink_endpoint& lhs, const netlink_endpoint& rhs)
- {
-- return (lhs.m_sockaddr < rhs.m_sockaddr);
-+ return (std::memcmp(&lhs.m_sockaddr, &rhs.m_sockaddr, sizeof(sockaddr_nl)) < 0);
- }
-
- private:
diff --git a/net-vpn/freelan/files/glibc225.patch b/net-vpn/freelan/files/glibc225.patch
deleted file mode 100644
index e21df29d1aec..000000000000
--- a/net-vpn/freelan/files/glibc225.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-commit 597b6eb65b4ea68f0fe8015db38ce68b71c280d7
-Author: Florian Lamprecht <florian_lamprecht@gmx.de>
-Date: Sun Mar 19 13:37:27 2017 +0100
-
- Fix a compiler warning on linux
-
- include a systemmacro explictly to avoid warning, which is handled as error.
-
-diff --git a/libs/asiotap/src/posix/posix_tap_adapter.cpp b/libs/asiotap/src/posix/posix_tap_adapter.cpp
-index 74e9eb2a..71377cee 100644
---- a/libs/asiotap/src/posix/posix_tap_adapter.cpp
-+++ b/libs/asiotap/src/posix/posix_tap_adapter.cpp
-@@ -56,7 +56,7 @@
- #ifdef LINUX
-
- #include <linux/if_tun.h>
--
-+#include <sys/sysmacros.h>
- /**
- * \struct in6_ifreq
- * \brief Replacement structure since the include of linux/ipv6.h introduces conflicts.
diff --git a/net-vpn/freelan/files/mf.patch b/net-vpn/freelan/files/mf.patch
deleted file mode 100644
index c7e169f4e8a7..000000000000
--- a/net-vpn/freelan/files/mf.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-commit 4109bb053906f45b545a6cca4399734b91bca425
-Author: Julien Kauffmann <julien.kauffmann@freelan.org>
-Date: Sat May 9 16:55:51 2015 -0400
-
- Fixed Makefile
-
-diff --git a/Makefile b/Makefile
-index d6bcd59..20b5ea1 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,14 +1,15 @@
- PRODUCT_NAME:=freelan
--PRODUCT_VERSION:=$(shell git describe)
-+PRODUCT_VERSION:=$(shell cat VERSION | tr -d '\r\n')
-+PRODUCT_PREFIX=/usr
-
--default: install
--
--install:
-- # Install the files to ${DESTDIR} (defaults to /)
-- scons install prefix=/
-+default: build
-
- build:
-- scons all samples
-+ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX}
-+
-+install:
-+ # Install the files to $(DESTDIR) (defaults to /)
-+ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX}
-
- package:
- git archive HEAD --prefix=${PRODUCT_NAME}-${PRODUCT_VERSION}/ | gzip > ${PRODUCT_NAME}-${PRODUCT_VERSION}.tar.gz
diff --git a/net-vpn/freelan/files/prefix.patch b/net-vpn/freelan/files/prefix.patch
deleted file mode 100644
index ac75e87fb1d1..000000000000
--- a/net-vpn/freelan/files/prefix.patch
+++ /dev/null
@@ -1,81 +0,0 @@
-commit d782a42eaeecdce9b4377a7b41dc60b9fecca31c
-Author: Julien Kauffmann <julien.kauffmann@freelan.org>
-Date: Sat May 9 19:30:11 2015 -0400
-
- Added support for a different binary prefix
-
-diff --git a/Makefile b/Makefile
-index 20b5ea1..b009d2c 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,15 +1,16 @@
- PRODUCT_NAME:=freelan
- PRODUCT_VERSION:=$(shell cat VERSION | tr -d '\r\n')
--PRODUCT_PREFIX=/usr
-+PRODUCT_BIN_PREFIX=/usr
-+PRODUCT_PREFIX=/
-
- default: build
-
- build:
-- FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX}
-+ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} scons --mode=release apps prefix=${PRODUCT_PREFIX} bin_prefix=${PRODUCT_BIN_PREFIX}
-
- install:
- # Install the files to $(DESTDIR) (defaults to /)
-- FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX}
-+ FREELAN_NO_GIT=1 FREELAN_NO_GIT_VERSION=${PRODUCT_VERSION} DESTDIR=$(DESTDIR) scons --mode=release install prefix=${PRODUCT_PREFIX} bin_prefix=${PRODUCT_BIN_PREFIX}
-
- package:
- git archive HEAD --prefix=${PRODUCT_NAME}-${PRODUCT_VERSION}/ | gzip > ${PRODUCT_NAME}-${PRODUCT_VERSION}.tar.gz
-diff --git a/SConstruct b/SConstruct
-index 32a9915..bc68b71 100644
---- a/SConstruct
-+++ b/SConstruct
-@@ -28,7 +28,7 @@ class FreelanEnvironment(Environment):
- A freelan specific environment class.
- """
-
-- def __init__(self, mode, prefix, **kwargs):
-+ def __init__(self, mode, prefix, bin_prefix=None, **kwargs):
- """
- Initialize the environment.
-
-@@ -66,14 +66,19 @@ class FreelanEnvironment(Environment):
-
- self.mode = mode
- self.prefix = prefix
-+ self.bin_prefix = bin_prefix if bin_prefix else prefix
- self.destdir = self['ENV'].get('DESTDIR', '')
-
- if self.destdir:
- self.install_prefix = os.path.normpath(
- os.path.abspath(self.destdir),
- ) + self.prefix
-+ self.bin_install_prefix = os.path.normpath(
-+ os.path.abspath(self.destdir),
-+ ) + self.bin_prefix
- else:
- self.install_prefix = self.prefix
-+ self.bin_install_prefix = self.bin_prefix
-
- if os.path.basename(self['CXX']) == 'clang++':
- self.Append(CXXFLAGS=['-Qunused-arguments'])
-@@ -147,10 +152,15 @@ class FreelanEnvironment(Environment):
- mode = GetOption('mode')
- prefix = os.path.normpath(os.path.abspath(ARGUMENTS.get('prefix', './install')))
-
-+if 'bin_prefix' in ARGUMENTS:
-+ bin_prefix = os.path.normpath(os.path.abspath(ARGUMENTS['bin_prefix']))
-+else:
-+ bin_prefix = None
-+
- if mode in ('all', 'release'):
-- env = FreelanEnvironment(mode='release', prefix=prefix)
-+ env = FreelanEnvironment(mode='release', prefix=prefix, bin_prefix=bin_prefix)
- libraries, includes, apps, samples, configurations = SConscript('SConscript', exports='env', variant_dir=os.path.join('build', env.mode))
-- install = env.Install(os.path.join(env.install_prefix, 'bin'), apps)
-+ install = env.Install(os.path.join(env.bin_install_prefix, 'bin'), apps)
- install.extend(env.Install(os.path.join(env.install_prefix, 'etc', 'freelan'), configurations))
-
- Alias('install', install)
diff --git a/net-vpn/freelan/freelan-2.0.ebuild b/net-vpn/freelan/freelan-2.0.ebuild
deleted file mode 100644
index eb641501a7e4..000000000000
--- a/net-vpn/freelan/freelan-2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit scons-utils toolchain-funcs eutils
-
-DESCRIPTION="Peer-to-peer VPN software that abstracts a LAN over the Internet"
-HOMEPAGE="http://www.freelan.org/"
-SRC_URI="https://github.com/freelan-developers/freelan/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug"
-
-DEPEND="
- dev-libs/boost:=[threads]
- dev-libs/openssl:0=
- net-misc/curl:=
- virtual/libiconv
-"
-RDEPEND="${DEPEND}"
-
-FREELAN_NO_GIT=1
-FREELAN_NO_GIT_VERSION=${PV}
-
-src_prepare() {
- epatch \
- "${FILESDIR}/boost158.patch" \
- "${FILESDIR}/mf.patch" \
- "${FILESDIR}/prefix.patch" \
- "${FILESDIR}/boost163.patch" \
- "${FILESDIR}/glibc225.patch" \
- "${FILESDIR}/gcc7.patch"
-
- sed -e "s/CXXFLAGS='-O3'/CXXFLAGS=''/" \
- -e "s/CXXFLAGS=\['-Werror'\]/CXXFLAGS=[]/" \
- -e "s/CXXFLAGS=\['-pedantic'\]/CXXFLAGS=[]/" \
- -i SConstruct || die
- epatch_user
-}
-
-src_compile() {
- tc-export CXX CC AR
- export LINK="$(tc-getCXX)"
-
- local MYSCONS=(
- "--mode=$(usex debug debug release)"
- prefix="${EPREFIX:-/}"
- bin_prefix="/usr"
- apps
- )
- escons "${MYSCONS[@]}"
-}
-
-src_install() {
- DESTDIR="${D}" escons --mode=release prefix="${EPREFIX:-/}" bin_prefix="/usr" install
- dodoc CONTRIBUTING.md README.md
-
- newinitd "${FILESDIR}/openrc/freelan.initd" freelan
-}