summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:15 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:59 +0100
commit44eb0385be457d97f5b85fff41ff78741f6f8b2d (patch)
treecaf2f153d3863b73410bb5a9767c373d3bf9e3b3
parentdev-haskell/quickcheck-classes: add 0.6.5.0 (diff)
downloadgentoo-44eb0385be457d97f5b85fff41ff78741f6f8b2d.tar.gz
gentoo-44eb0385be457d97f5b85fff41ff78741f6f8b2d.tar.bz2
gentoo-44eb0385be457d97f5b85fff41ff78741f6f8b2d.zip
dev-haskell/quickcheck: add 2.14.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/quickcheck/Manifest1
-rw-r--r--dev-haskell/quickcheck/metadata.xml17
-rw-r--r--dev-haskell/quickcheck/quickcheck-2.14.3.ebuild36
3 files changed, 39 insertions, 15 deletions
diff --git a/dev-haskell/quickcheck/Manifest b/dev-haskell/quickcheck/Manifest
index 2496e36b3faf..337abbc91663 100644
--- a/dev-haskell/quickcheck/Manifest
+++ b/dev-haskell/quickcheck/Manifest
@@ -1 +1,2 @@
DIST QuickCheck-2.14.2.tar.gz 75246 BLAKE2B a64ad51f3daa858a224c00fb785979460b638d76f20c7a19d95a6303cd5da61adaa40cb52e154dd15218adbf54fff184f16ab3b932895294cf37f24982a2b9cc SHA512 84decd354e6093bc72afd125410499dd4be3ae8fdbf0a3b466011b4dbcb5c5657e51ab75cfe22790e22bf4ac54cbb1203ff7a0d108e872ce60f4831be827a6e5
+DIST quickcheck-2.14.3.tar.gz 76849 BLAKE2B e3a0eefaebd27fe5e11c4ed8dd7120b42e688be1cd249ee88a8b6b25a248376fae6d3f2f0506f675040314e019baeb60eac993421a0a7d87f821cdab01e93be5 SHA512 d00499fcdbe66d384a40c66a0d01dfe80f0622599f2f19ab569b45ef13c8d726c855b4687c7a1be022ea22df4bc66c48cf12fc156fadc558714fccc5a3deef7e
diff --git a/dev-haskell/quickcheck/metadata.xml b/dev-haskell/quickcheck/metadata.xml
index c64f613cab7c..6d0a1dba3e0c 100644
--- a/dev-haskell/quickcheck/metadata.xml
+++ b/dev-haskell/quickcheck/metadata.xml
@@ -6,23 +6,10 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
- <flag name="template-haskell">Enable additional test modules requiring Template Haskell support.</flag>
+ <flag name="template-haskell">Build Test.QuickCheck.All, which uses Template Haskell.</flag>
</use>
- <longdescription>
- QuickCheck is a library for random testing of program properties.
-
- The programmer provides a specification of the program, in
- the form of properties which functions should satisfy, and
- QuickCheck then tests that the properties hold in a large number
- of randomly generated cases.
-
- Specifications are expressed in
- Haskell, using combinators defined in the QuickCheck library.
- QuickCheck provides combinators to define properties, observe
- the distribution of test data, and define test
- data generators.
- </longdescription>
<upstream>
+ <remote-id type="hackage">QuickCheck</remote-id>
<remote-id type="github">nick8325/quickcheck</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild b/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
new file mode 100644
index 000000000000..bcfff140bd41
--- /dev/null
+++ b/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: +base4,-base3,-old-random,templatehaskell:template-haskell
+
+CABAL_PN="QuickCheck"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Automatic testing of Haskell programs"
+HOMEPAGE="https://github.com/nick8325/quickcheck"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
+IUSE="+template-haskell"
+
+RDEPEND=">=dev-haskell/random-1.2.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-base3 \
+ --flag=base4 \
+ --flag=-old-random \
+ $(cabal_flag template-haskell templatehaskell)
+}