summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-06 16:53:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-06 17:29:40 +0200
commit45ba26d20c6427c4c22668383c81d6ad2f180016 (patch)
tree8603aeea4f0e7d5d773f52e299e95f4ea839f92e
parentdev-python/sentry-sdk: Bump to 2.1.1 (diff)
downloadgentoo-45ba26d20c6427c4c22668383c81d6ad2f180016.tar.gz
gentoo-45ba26d20c6427c4c22668383c81d6ad2f180016.tar.bz2
gentoo-45ba26d20c6427c4c22668383c81d6ad2f180016.zip
dev-python/python-mpv: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-mpv/Manifest1
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-mpv/Manifest b/dev-python/python-mpv/Manifest
index 033afa103a47..22b8437cf70f 100644
--- a/dev-python/python-mpv/Manifest
+++ b/dev-python/python-mpv/Manifest
@@ -1 +1,2 @@
DIST python-mpv-1.0.5.gh.tar.gz 211622 BLAKE2B eeda4e61c8e2728898ddae7c2cd9e92a7cf718b22aefd8104edf361b7d7feab7655561019cbed35045cbdc4faac96e0d85c77d053bfae61e05052a981bd00342 SHA512 cefc0b38146d707a06e2b9e58951675be8d236c95e24de7665085641b24f7d7d5303130ebdb4c97f4f4c79b6de393c30656d9fc0dabf6760156d4aca8207d77c
+DIST python-mpv-1.0.6.gh.tar.gz 212503 BLAKE2B f0b63116f90b0d9e0be7d1f7e3586390d1486a89fd2eee8362f0e569b397a9d61dd597b39307559ea4206fdb98c70bbb09e07fbcbc64d60026b21522c1396053 SHA512 f5848f62f978372b04d09e89e9d04b64ff0c437a1f9f63c4ba4751bbe4a8bd0eb20e7503a3f25c7ca64ef0ab5c91db8be68473dbc29a04d78a9246ed784bcc38
diff --git a/dev-python/python-mpv/python-mpv-1.0.6.ebuild b/dev-python/python-mpv/python-mpv-1.0.6.ebuild
new file mode 100644
index 000000000000..6b9246e27c40
--- /dev/null
+++ b/dev-python/python-mpv/python-mpv-1.0.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to the mpv media player"
+HOMEPAGE="
+ https://github.com/jaseg/python-mpv/
+ https://pypi.org/project/python-mpv/
+"
+SRC_URI="
+ https://github.com/jaseg/python-mpv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ media-video/mpv[libmpv]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # hanging tests
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_event_overflow
+ tests/test_mpv.py::TestStreams::test_custom_stream
+ )
+
+ virtx epytest
+}