summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 09:25:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 09:26:15 +0200
commit460c696fad0c0b5a215587f69260f8cbdc8eadb4 (patch)
treecbdbf7ab6a2a6297986dd120ef3ac399833eabab
parentdev-ml/ppx_import: Remove old (diff)
downloadgentoo-460c696fad0c0b5a215587f69260f8cbdc8eadb4.tar.gz
gentoo-460c696fad0c0b5a215587f69260f8cbdc8eadb4.tar.bz2
gentoo-460c696fad0c0b5a215587f69260f8cbdc8eadb4.zip
dev-ml/ppx_import: convert to opam.eclass
Package-Manager: Portage-2.3.7, Repoman-2.3.3
-rw-r--r--dev-ml/ppx_import/ppx_import-1.2.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/dev-ml/ppx_import/ppx_import-1.2.ebuild b/dev-ml/ppx_import/ppx_import-1.2.ebuild
index 4bb61dd8e171..efecbd3f7200 100644
--- a/dev-ml/ppx_import/ppx_import-1.2.ebuild
+++ b/dev-ml/ppx_import/ppx_import-1.2.ebuild
@@ -3,6 +3,8 @@
EAPI=5
+inherit opam
+
DESCRIPTION="A syntax extension for importing declarations from interface files"
HOMEPAGE="https://github.com/whitequark/ppx_import"
SRC_URI="https://github.com/whitequark/ppx_import/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -20,7 +22,6 @@ DEPEND="
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
test? ( dev-ml/ounit dev-ml/ppx_deriving )
- dev-ml/opam
dev-ml/ocamlbuild
dev-ml/findlib
"
@@ -36,12 +37,3 @@ src_compile() {
src_test() {
ocamlbuild -classic-display -use-ocamlfind src_test/test_ppx_import.byte -- || die
}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${T}/dontinstallit" \
- ${PN}.install || die
- dodoc CHANGELOG.md README.md
-}