summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-21 02:11:04 +0000
committerSam James <sam@gentoo.org>2024-03-21 02:11:43 +0000
commit473e734fcd8134efa0067a8cfc6a2f23400697ba (patch)
tree4e17a8c272f4d9b6175b877e69854f7fac2387ab
parentdev-util/intel_clc: Keyword 9999 x86, #926226 (diff)
downloadgentoo-473e734fcd8134efa0067a8cfc6a2f23400697ba.tar.gz
gentoo-473e734fcd8134efa0067a8cfc6a2f23400697ba.tar.bz2
gentoo-473e734fcd8134efa0067a8cfc6a2f23400697ba.zip
net-misc/streamlink: add 6.7.1
Bit awkward as we have to require brand new trio and still-masked pytest (=> skip the relevant tests for now on the latter). Closes: https://bugs.gentoo.org/927330 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-6.7.1.ebuild98
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild28
3 files changed, 125 insertions, 2 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 21d6469dd326..e2148eb0a7f3 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-6.5.1.tar.gz 717297 BLAKE2B 7f24a9ac2e62ff08d2126e4aceda75cbd46d78de08784336dd3b4d7608cd7885a5dca28bd9dda9f8c217b9cc428f8f50f09d0c45e470e0d3534ecd3effb2a95f SHA512 b31b34a2ef510d47d396b12b770c042bed24ff61835db6a654722803ae94e8371aa547f30bf20d7cf34d737ed9bd59bcea1bb1810e926cfc7ae3fa72f38881d8
DIST streamlink-6.6.2.tar.gz 737076 BLAKE2B f1603c292cbb1135534d34b89bad3d859194a9d9b602aafc05e38d901071b77a92fc054387081a4579a4504642d33454427ee239def80a8ec0b50f901dab05ab SHA512 727fbd6bbf03a55a468b625984abe3d7f1792aaab11b2a55d5b0526454cc1959d7bfb3579526eb9e7493a44277302e6f40556f3ad99509751f950d49605b60db
DIST streamlink-6.7.0.tar.gz 738338 BLAKE2B 2ef297c8c96716d71b1e8148397e2a9f079062a83d9533568eabf9777e832dfc56eb4d4ec0ef361250af80be66c7e4680fe7c72d070ee85da85f74917cf0d88b SHA512 df2f69cdd4de9deca41d7dca2b8b38dabcda9f4722de28a96fca0b011cb528751e40895cbe68724c3222615c6e317983d8937bd2c161640d3a8c6db17273cafd
+DIST streamlink-6.7.1.tar.gz 740537 BLAKE2B 676f9e64d80c45edbca89a7fad0f91efd8c3528ec8c8a3143aa7f277a2b882237c65b4d6c50752e3d4ca60f179012b7bb1db0b7555a95459b423adea9f982919 SHA512 2a76d819b15efbe7b7bf4912b5117ab6c2a0fb49a7aac74559c0fc9bb7ac989cb589bcdfb84d8908a6b6c163080bdb2211d53b8e5de7840cde1a38eea45bcfac
diff --git a/net-misc/streamlink/streamlink-6.7.1.ebuild b/net-misc/streamlink/streamlink-6.7.1.ebuild
new file mode 100644
index 000000000000..726f048e9ad9
--- /dev/null
+++ b/net-misc/streamlink/streamlink-6.7.1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+# >= 6.2.1 uses a bunch of setuptools hooks instead of vanilla setuptools
+# https://github.com/streamlink/streamlink/commit/194d9bc193f5285bc1ba33af5fd89209a96ad3a7
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+# See https://github.com/streamlink/streamlink/pull/5895 re exceptiongroup dep
+RDEPEND="
+ media-video/ffmpeg
+ $(python_gen_cond_dep '
+ dev-python/certifi[${PYTHON_USEDEP}]
+ || (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ )
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-1.2.1[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/setuptools-64[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+ ')
+"
+
+if [[ ${PV} == 9999* ]]; then
+ RDEPEND+="
+ $(python_gen_cond_dep '
+ >=dev-python/versioningit-2.0.0[${PYTHON_USEDEP}]
+ ')
+ "
+fi
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip tests requiring <dev-python/pytest-8.0.0 which is currently masked
+ # https://github.com/streamlink/streamlink/pull/5901
+ EPYTEST_DESELECT+=(
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_exception
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_error
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_detach
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_error
+ tests/webbrowser/cdp/test_connection.py::TestCreateConnection::test_failure
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_invalid_json
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_unknown_session_id
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Default timeout, response not in time]'
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Custom timeout, response not in time]'
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_bad_command
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_result_exception
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_error
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_no_result
+ )
+
+ epytest
+}
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index d73952536218..726f048e9ad9 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ if [[ ${PV} != 9999* ]]; then
fi
# See https://github.com/streamlink/streamlink/commit/9d8156dd794ee0919297cd90d85bcc11b8a28358 for chardet/charset-normalizer dep
+# See https://github.com/streamlink/streamlink/pull/5895 re exceptiongroup dep
RDEPEND="
media-video/ffmpeg
$(python_gen_cond_dep '
@@ -38,6 +39,7 @@ RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/charset-normalizer[${PYTHON_USEDEP}]
)
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
>=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
dev-python/isodate[${PYTHON_USEDEP}]
>=dev-python/lxml-4.6.4[${PYTHON_USEDEP}]
@@ -45,7 +47,7 @@ RDEPEND="
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
>dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
- >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.25.0[${PYTHON_USEDEP}]
>=dev-python/trio-websocket-0.9.0[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.26.0[${PYTHON_USEDEP}]
')
@@ -72,3 +74,25 @@ if [[ ${PV} == 9999* ]]; then
fi
distutils_enable_tests pytest
+
+python_test() {
+ # Skip tests requiring <dev-python/pytest-8.0.0 which is currently masked
+ # https://github.com/streamlink/streamlink/pull/5901
+ EPYTEST_DESELECT+=(
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_exception
+ tests/webbrowser/cdp/test_client.py::TestEvaluate::test_error
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_detach
+ tests/webbrowser/cdp/test_client.py::TestNavigate::test_error
+ tests/webbrowser/cdp/test_connection.py::TestCreateConnection::test_failure
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_invalid_json
+ tests/webbrowser/cdp/test_connection.py::TestReaderError::test_unknown_session_id
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Default timeout, response not in time]'
+ 'tests/webbrowser/cdp/test_connection.py::TestSend::test_timeout[Custom timeout, response not in time]'
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_bad_command
+ tests/webbrowser/cdp/test_connection.py::TestSend::test_result_exception
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_error
+ tests/webbrowser/cdp/test_connection.py::TestHandleCmdResponse::test_response_no_result
+ )
+
+ epytest
+}