summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-05-08 13:30:27 +0400
committerSam James <sam@gentoo.org>2024-05-09 02:09:05 +0100
commit4919e107f95d762348df57ca9a8e75307d9222bc (patch)
treeee712273f3c88334cb4d58e3bc463856f3fb0ae6
parentsci-electronics/irsim: move patches to devspace (diff)
downloadgentoo-4919e107f95d762348df57ca9a8e75307d9222bc.tar.gz
gentoo-4919e107f95d762348df57ca9a8e75307d9222bc.tar.bz2
gentoo-4919e107f95d762348df57ca9a8e75307d9222bc.zip
sci-biology/hmmer: Add missing include into configure
There are no autotools source files, so we can't just autoreconf the problem out of existence [sam: Revbump.] Closes: https://bugs.gentoo.org/900551 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36599 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-biology/hmmer/files/hmmer-2.3.2-fix-missing-include-in-configure.patch18
-rw-r--r--sci-biology/hmmer/hmmer-2.3.2-r6.ebuild (renamed from sci-biology/hmmer/hmmer-2.3.2-r5.ebuild)3
2 files changed, 20 insertions, 1 deletions
diff --git a/sci-biology/hmmer/files/hmmer-2.3.2-fix-missing-include-in-configure.patch b/sci-biology/hmmer/files/hmmer-2.3.2-fix-missing-include-in-configure.patch
new file mode 100644
index 000000000000..37683d425edb
--- /dev/null
+++ b/sci-biology/hmmer/files/hmmer-2.3.2-fix-missing-include-in-configure.patch
@@ -0,0 +1,18 @@
+--- a/squid/configure 2024-05-08 09:21:15.751063495 -0000
++++ b/squid/configure 2024-05-08 09:22:50.491502934 -0000
+@@ -2493,6 +2493,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <stdlib.h>
+ int
+ main ()
+ {
+@@ -3500,6 +3501,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <ctype.h>
++#include <stdlib.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
diff --git a/sci-biology/hmmer/hmmer-2.3.2-r5.ebuild b/sci-biology/hmmer/hmmer-2.3.2-r6.ebuild
index b305820faff3..74a8a151b0c4 100644
--- a/sci-biology/hmmer/hmmer-2.3.2-r5.ebuild
+++ b/sci-biology/hmmer/hmmer-2.3.2-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,6 +20,7 @@ BDEPEND="test? ( dev-lang/perl )"
PATCHES=(
"${FILESDIR}/${P}-fix-perl-shebangs.patch"
"${FILESDIR}/${P}-fix-build-system-destdir.patch"
+ "${FILESDIR}/${P}-fix-missing-include-in-configure.patch"
)
src_configure() {