summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-02 07:31:05 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-02 08:05:32 +0200
commit4a3fdd71886fb9cba33f8d80b3ab6209fd667725 (patch)
tree1b93e476502da8d6479602004142c8b63844cfdc
parentdev-python/trimesh: Bump to 3.23.0 (diff)
downloadgentoo-4a3fdd71886fb9cba33f8d80b3ab6209fd667725.tar.gz
gentoo-4a3fdd71886fb9cba33f8d80b3ab6209fd667725.tar.bz2
gentoo-4a3fdd71886fb9cba33f8d80b3ab6209fd667725.zip
dev-python/rdflib: Bump to 7.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rdflib/Manifest1
-rw-r--r--dev-python/rdflib/rdflib-7.0.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
index ab5d2f1c1ea5..d77be589b1f6 100644
--- a/dev-python/rdflib/Manifest
+++ b/dev-python/rdflib/Manifest
@@ -1 +1,2 @@
DIST rdflib-6.3.2.tar.gz 4749592 BLAKE2B 5f7832934e3b42387f7c792341d0aee9765d179beb409a8c92ed0251715be70a79a5ac71022f4599804b489acd2695a32a033e8aa73aa174d8393330b4c21750 SHA512 682554114456269ecd5a20433e31030e2ae85ccf84400060420433cba317eb272649a38c2c75f0d4ada878c391683f8a422452d24b2f8a41c28e99b977e2b557
+DIST rdflib-7.0.0.tar.gz 4765796 BLAKE2B 60ca36160f4f6588892853adde9dd4b795e549cc7fd52127cf1e50de3853b25b3a333cabd584ccf22827cb6f89d215d225c4ba767d0775feeefb481e4b1ed93b SHA512 56d110ab24c74c6ddb2e75320f60a82b4945e6ea1ce9d10ad4ae53d44c679b35826e3d7406e7d0e321ef9b042d32d2ba327a6dbd5c2c1780f552131d80c09445
diff --git a/dev-python/rdflib/rdflib-7.0.0.ebuild b/dev-python/rdflib/rdflib-7.0.0.ebuild
new file mode 100644
index 000000000000..3a87e93233ba
--- /dev/null
+++ b/dev-python/rdflib/rdflib-7.0.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite?,threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="
+ https://github.com/RDFLib/rdflib/
+ https://pypi.org/project/rdflib/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples sqlite"
+
+RDEPEND="
+ <dev-python/isodate-1[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.6.0[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ <dev-python/pyparsing-4[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # doctests require internet
+ sed -i -e '/doctest-modules/d' pyproject.toml || die
+
+ # we disable pytest-cov
+ sed -i -e 's@, no_cover: None@@' test/test_misc/test_plugins.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not webtest"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}