summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-07-08 01:53:29 +0300
committerSam James <sam@gentoo.org>2022-07-08 23:09:44 +0100
commit4a6bd64dbae54a5de416c0af6ceb714601a63c82 (patch)
tree772f46a5a3e48ce3550efcb33a21d9435ca6536f
parentmedia-video/mkvtoolnix: Make dependency on qtsvg conditional (diff)
downloadgentoo-4a6bd64dbae54a5de416c0af6ceb714601a63c82.tar.gz
gentoo-4a6bd64dbae54a5de416c0af6ceb714601a63c82.tar.bz2
gentoo-4a6bd64dbae54a5de416c0af6ceb714601a63c82.zip
media-sound/pulseaudio: Bump metapackage to 16.1, drop default USE daemon
All packages which need real pulseaudio daemon (e.g. need extension modules which are only implemented for real pulseaudio daemon, or just work with real pulseaudio daemon only) already depend on media-sound/pulseaudio-daemon as an alternative to media-sound/pulseaudio[daemon]. Drop default USE +daemon from metapackage to allow cleaning up media-sound/pulseaudio-daemon if USE daemon is not set by user. Client libs package media-libs/libpulse will still make sure that one of available pulseaudio server implementations is installed, but will not enforce any particular choice. To change pulseaudio server implementation to pipewire make sure neither media-sound/pulseaudio nor media-sound/pulseaudio-daemon are in the @world and USE daemon is not set for media-sound/pulseaudio, then set USE sound-server for media-video/pipewire and update as usual: emerge -avtuDU @world To change pulseaudio server implementation to pulseaudio-daemon remove USE sound-server from media-video/pipewire and update like this: emerge -avtuDU --oneshot @world pulseaudio-daemon Bug: https://bugs.gentoo.org/856745 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26273 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/pulseaudio/pulseaudio-16.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/pulseaudio/pulseaudio-16.1.ebuild b/media-sound/pulseaudio/pulseaudio-16.1.ebuild
new file mode 100644
index 000000000000..a4098093c08f
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-16.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+DESCRIPTION="A meta package for PulseAudio (networked sound server)"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+SRC_URI=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="metapackage"
+
+SLOT="0"
+
+# NOTE: bluetooth and ofono-headset are passed through to
+# pulseaudio-daemon dependency to make sure users who have bluetooth enabled
+# just for pulseaudio package will also get these enabled via metapackage.
+IUSE="bluetooth daemon +glib jack ofono-headset"
+
+RDEPEND="
+ >=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
+ daemon? ( >=media-sound/pulseaudio-daemon-${PV}[bluetooth?,glib?,jack?,ofono-headset?] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"