summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-28 08:31:27 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-28 09:28:32 +0100
commit4a7a48b5b90297016d123ab3923b5dec4bb2ae7f (patch)
tree6c6afb3235ce88bec6978ad56da82e313957c5b1
parentdev-python/astroid: Bump to 2.10.0 (diff)
downloadgentoo-4a7a48b5b90297016d123ab3923b5dec4bb2ae7f.tar.gz
gentoo-4a7a48b5b90297016d123ab3923b5dec4bb2ae7f.tar.bz2
gentoo-4a7a48b5b90297016d123ab3923b5dec4bb2ae7f.zip
dev-python/slixmpp: Bump to 1.8.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.0.1.ebuild36
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild6
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index f2266da4ea51..9f186289bf7f 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.7.1.tar.gz 931753 BLAKE2B 3de14be36353bc5f5f2cfbe002c44c5e843a7b36fa31a9dd315e363fc67e36d080df0dc70d82e65c6802c41377c2e98f56ff4e23cc5e9a92165c3d3b7565493f SHA512 5a59fcbb901e6f4456049f1ec2bbf781b1ec7c5a3ad4b66216d4c5daffa7f0606f74b941647fe2b53e6c8cdc476371305c7b7a2ca24d21450e19548f888be3b1
+DIST slixmpp-1.8.0.1.tar.gz 532519 BLAKE2B c4cda06d1d16ef92404263a90a6abbba46e526b4f9edc54228757b73c9faa0f04e9340ea80b5f0491017bad04094512bd25fe04fc095742b639cecba73db058b SHA512 0bfa39f126f2154702e160117b619f41319362723226ebf0ed4b803aafef0302d4df9d9a4cff5fd890507a10ac7424a07cc3bece519451bd56be400998dc0178
diff --git a/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild b/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild
new file mode 100644
index 000000000000..1a7f67fcb5c6
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ net-dns/libidn
+"
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
index 4c7eb16a1e1b..1a7f67fcb5c6 100644
--- a/dev-python/slixmpp/slixmpp-9999.ebuild
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -26,6 +27,7 @@ DEPEND="
RDEPEND="
dev-python/aiodns[${PYTHON_USEDEP}]
dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
${DEPEND}