summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-03-14 13:51:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-16 21:18:11 +0200
commit4afb75c3e499e6957e81aaca2cfa1f9312b453aa (patch)
treec4bbb55f8d9a617c6a45fda76614dfe7e9aa2924
parentgui-libs/wayfire-plugins-extra: add 0.8.1 (diff)
downloadgentoo-4afb75c3e499e6957e81aaca2cfa1f9312b453aa.tar.gz
gentoo-4afb75c3e499e6957e81aaca2cfa1f9312b453aa.tar.bz2
gentoo-4afb75c3e499e6957e81aaca2cfa1f9312b453aa.zip
gui-libs/wayfire-plugins-extra: update live ebuild
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
index 245409005bf2..72311100c56b 100644
--- a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,10 +11,10 @@ HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
- SLOT="0/9999"
+ SLOT="0/0.9"
else
SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64"
SLOT="0/$(ver_cut 1-2)"
fi
@@ -23,12 +23,21 @@ LICENSE="MIT"
# no tests
RESTRICT="test"
+WAYFIRE_REVDEP="
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gui-libs/wf-config:=
+ gui-libs/wlroots:=
+ x11-libs/cairo
+"
+
DEPEND="
+ ${WAYFIRE_REVDEP}
dev-cpp/glibmm:2
dev-cpp/nlohmann_json
dev-libs/libevdev
dev-libs/wayland
- gui-wm/wayfire:${SLOT}
+ >=gui-wm/wayfire-0.9.0
"
RDEPEND="${DEPEND}"
BDEPEND="