summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-08 23:49:46 +0100
committerSam James <sam@gentoo.org>2022-06-08 23:50:41 +0100
commit4b407d884e293e6aef7249862f3046ae235a052b (patch)
tree588079ba118b6b25a4cc39f5fbaefa0fc59020fa
parentnet-p2p/syncthing: add 1.20.2, drop 1.20.1 (diff)
downloadgentoo-4b407d884e293e6aef7249862f3046ae235a052b.tar.gz
gentoo-4b407d884e293e6aef7249862f3046ae235a052b.tar.bz2
gentoo-4b407d884e293e6aef7249862f3046ae235a052b.zip
app-admin/github-backup-utils: call python-any-r1_pkg_setup conditionally
As per example in the Python guide. Python is only needed for tests here, but as-is, it'll check for Python on all emerges, which is a problem if e.g. upgrading an old system, Python has partly been upgraded, but not completely yet, then the emerge will die and the system may be left in a bad state. (i.e. the pkg_setup call should match the dependency.) Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-admin/github-backup-utils/github-backup-utils-3.5.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-admin/github-backup-utils/github-backup-utils-3.5.0.ebuild b/app-admin/github-backup-utils/github-backup-utils-3.5.0.ebuild
index fd36dcb57253..ab24755a1ddf 100644
--- a/app-admin/github-backup-utils/github-backup-utils-3.5.0.ebuild
+++ b/app-admin/github-backup-utils/github-backup-utils-3.5.0.ebuild
@@ -34,6 +34,10 @@ DEPEND="test? (
MY_PN="${PN/#github-/}"
S="${WORKDIR}/${MY_PN}-${PV}"
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_compile() {
:;
}