summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-08 17:59:05 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-08 17:59:30 +0100
commit4b7eb5c8427439702410d4e83a3de65e173cac29 (patch)
treed9a1e0614cb3f001ef042d7a72fc7910130d2ee2
parentsys-libs/openipmi: fix modern C issue w/ USE=perl (diff)
downloadgentoo-4b7eb5c8427439702410d4e83a3de65e173cac29.tar.gz
gentoo-4b7eb5c8427439702410d4e83a3de65e173cac29.tar.bz2
gentoo-4b7eb5c8427439702410d4e83a3de65e173cac29.zip
dev-python/google-auth-oauthlib: Fix installing stray files
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch25
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild (renamed from dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild)7
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
new file mode 100644
index 000000000000..61349d1cce43
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/files/google-auth-oauthlib-1.2.0-setup-exclude.patch
@@ -0,0 +1,25 @@
+From dffa74bf7cb25d4e7759b4d0cded68eabfaaf33b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 8 Jan 2024 15:58:00 +0100
+Subject: [PATCH] fix: do not include docs/conf.py & scripts in wheel
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index ea9796a..430db0c 100644
+--- a/setup.py
++++ b/setup.py
+@@ -37,7 +37,7 @@ setup(
+ description="Google Authentication Library",
+ long_description=long_description,
+ url="https://github.com/GoogleCloudPlatform/google-auth-library-python-oauthlib",
+- packages=find_namespace_packages(exclude=("tests*",)),
++ packages=find_namespace_packages(exclude=("docs*", "scripts*", "tests*",)),
+ install_requires=DEPENDENCIES,
+ extras_require={"tool": TOOL_DEPENDENCIES},
+ entry_points={
+--
+2.43.0
+
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
index 395c2d95e16a..04dbde55c9ab 100644
--- a/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0.ebuild
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-1.2.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -37,3 +37,8 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/googleapis/google-auth-library-python-oauthlib/pull/328
+ "${FILESDIR}/${P}-setup-exclude.patch"
+)