summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-09 21:23:08 +0000
committerSam James <sam@gentoo.org>2024-03-09 21:23:08 +0000
commit4c8375e12db9421a1155f034705b68fdbe8f928e (patch)
tree2ac1218f5cdd60ea662f1c428ec0927b7a181697
parentnet-wireless/wpa_supplicant: drop 2.10-r1, 2.10-r2 (diff)
downloadgentoo-4c8375e12db9421a1155f034705b68fdbe8f928e.tar.gz
gentoo-4c8375e12db9421a1155f034705b68fdbe8f928e.tar.bz2
gentoo-4c8375e12db9421a1155f034705b68fdbe8f928e.zip
net-wireless/wpa_supplicant: always install OpenRC init script, cleanup cruft
I haven't dug into the historical reasons for the has_version here, my guess is it relied on some newer OpenRC feature rather than intentionally omitting for systemd machines (where the small file policy applies in both directions). Always install them accordingly. Also, cleanup an ancient <baselayout-2 hack. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-2.10-r4.ebuild (renamed from net-wireless/wpa_supplicant/wpa_supplicant-2.10-r3.ebuild)16
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild19
2 files changed, 8 insertions, 27 deletions
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r3.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r4.ebuild
index b4b8610aa549..5778596a4275 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r3.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-2.10-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -389,18 +389,8 @@ src_install() {
use privsep && dosbin wpa_priv
dobin wpa_cli wpa_passphrase
- # baselayout-1 compat
- if has_version "<sys-apps/baselayout-2.0.0"; then
- dodir /sbin
- dosym ../usr/sbin/wpa_supplicant /sbin/wpa_supplicant
- dodir /bin
- dosym ../usr/bin/wpa_cli /bin/wpa_cli
- fi
-
- if has_version ">=sys-apps/openrc-0.5.0"; then
- newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
- newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
- fi
+ newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
+ newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
exeinto /etc/wpa_supplicant/
newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
index 8c93c31c2554..5778596a4275 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,7 +13,7 @@ if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://w1.fi/hostap.git"
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
SRC_URI="https://w1.fi/releases/${P}.tar.gz"
fi
@@ -124,6 +124,7 @@ src_prepare() {
# bug (912315)
eapply "${FILESDIR}/${PN}-2.10-allow-legacy-renegotiation.patch"
+ eapply "${FILESDIR}/${P}-Drop-security-level-to-0-with-OpenSSL-3.0-wh.patch"
# bug (640492)
sed -i 's#-Werror ##' wpa_supplicant/Makefile || die
@@ -388,18 +389,8 @@ src_install() {
use privsep && dosbin wpa_priv
dobin wpa_cli wpa_passphrase
- # baselayout-1 compat
- if has_version "<sys-apps/baselayout-2.0.0"; then
- dodir /sbin
- dosym ../usr/sbin/wpa_supplicant /sbin/wpa_supplicant
- dodir /bin
- dosym ../usr/bin/wpa_cli /bin/wpa_cli
- fi
-
- if has_version ">=sys-apps/openrc-0.5.0"; then
- newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
- newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
- fi
+ newinitd "${FILESDIR}/${PN}-init.d" wpa_supplicant
+ newconfd "${FILESDIR}/${PN}-conf.d" wpa_supplicant
exeinto /etc/wpa_supplicant/
newexe "${FILESDIR}/wpa_cli.sh" wpa_cli.sh