summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-19 16:55:53 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-09-14 23:22:37 +0200
commit4cce249ad0e78ba872c248a96e169b694b0555ee (patch)
tree93ac96cdf0fa5014537c0d98e47d25d7502c1fc0
parentapp-vim/fluxbox-syntax: EAPI8 bump (diff)
downloadgentoo-4cce249ad0e78ba872c248a96e169b694b0555ee.tar.gz
gentoo-4cce249ad0e78ba872c248a96e169b694b0555ee.tar.bz2
gentoo-4cce249ad0e78ba872c248a96e169b694b0555ee.zip
app-vim/foldutil: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-vim/foldutil/foldutil-3.0-r2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/foldutil/foldutil-3.0-r2.ebuild b/app-vim/foldutil/foldutil-3.0-r2.ebuild
new file mode 100644
index 000000000000..24e498bbfa3e
--- /dev/null
+++ b/app-vim/foldutil/foldutil-3.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fold creation utility"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=158"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=app-vim/genutils-2.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a number of commands for working with folds:
+\ :FoldNonMatching [pattern] [context]
+\ :FoldShowLines {lines} [context]
+\ :FoldEndFolding"