summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-04-27 17:59:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-04-27 17:59:46 +0300
commit4e76e5b45022d702af9a61fd2d65787b222b6d40 (patch)
tree680139552cf91177efe6a1077cf9dd0ceccae52a
parentapp-misc/tek: treeclean (diff)
downloadgentoo-4e76e5b45022d702af9a61fd2d65787b222b6d40.tar.gz
gentoo-4e76e5b45022d702af9a61fd2d65787b222b6d40.tar.bz2
gentoo-4e76e5b45022d702af9a61fd2d65787b222b6d40.zip
sci-biology/HTSeq: treeclean
Closes: https://bugs.gentoo.org/910015 Bug: https://bugs.gentoo.org/923242 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--profiles/package.mask6
-rw-r--r--sci-biology/HTSeq/HTSeq-2.0.2.ebuild66
-rw-r--r--sci-biology/HTSeq/HTSeq-9999.ebuild66
-rw-r--r--sci-biology/HTSeq/Manifest1
-rw-r--r--sci-biology/HTSeq/metadata.xml12
5 files changed, 0 insertions, 151 deletions
diff --git a/profiles/package.mask b/profiles/package.mask
index 4316edbc5c4f..15c680723ac1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -358,12 +358,6 @@ sys-firmware/bluez-firmware
dev-python/sumtypes
# Michał Górny <mgorny@gentoo.org> (2024-03-26)
-# Uses deprecated distutils-r1 API. The current version is outdated,
-# from mid-2022. No reverse dependencies.
-# Removal on 2024-04-25. Bug #910015.
-sci-biology/HTSeq
-
-# Michał Górny <mgorny@gentoo.org> (2024-03-26)
# Uses deprecated distutils-r1 API. Depends on dev-qt/qtwebengine:5.
# Includes the libraries with no other reverse dependencies.
# Removal on 2024-04-25. Bug #909996.
diff --git a/sci-biology/HTSeq/HTSeq-2.0.2.ebuild b/sci-biology/HTSeq/HTSeq-2.0.2.ebuild
deleted file mode 100644
index b4b7974e60d0..000000000000
--- a/sci-biology/HTSeq/HTSeq-2.0.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_IN_SOURCE_BUILD=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
-HOMEPAGE="https://htseq.readthedocs.io/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/htseq/htseq.git"
-else
- SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.gh.tar.gz"
-
- S="${WORKDIR}"/htseq-release_${PV}
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )"
-BDEPEND="
- >=dev-lang/swig-3.0.8
- dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_configure() {
- # mask broken asserts in src/step_vector.h:72
- append-cppflags -DNDEBUG
-
- distutils-r1_src_configure
-}
-
-python_test() {
- distutils_install_for_testing
-
- # Due to the build directories creating a competing
- # hierarchy, we move to the test/ dir to avoid implicitly
- # injecting the root HTSeq/ dir into the PYTHONPATH,
- # which leads the python module lookup astray:
- # ${PWD}
- # ├── build
- # │ ├── lib
- # │ │ └── HTSeq
- # │ [...]
- # ├── HTSeq
- # └── test
- cd test/ || die
- ln -s ../example_data || die
- epytest
-}
diff --git a/sci-biology/HTSeq/HTSeq-9999.ebuild b/sci-biology/HTSeq/HTSeq-9999.ebuild
deleted file mode 100644
index b4b7974e60d0..000000000000
--- a/sci-biology/HTSeq/HTSeq-9999.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_IN_SOURCE_BUILD=1
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
-HOMEPAGE="https://htseq.readthedocs.io/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/htseq/htseq.git"
-else
- SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.gh.tar.gz"
-
- S="${WORKDIR}"/htseq-release_${PV}
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3+"
-SLOT="0"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- )"
-BDEPEND="
- >=dev-lang/swig-3.0.8
- dev-python/cython[${PYTHON_USEDEP}]"
-
-distutils_enable_tests pytest
-
-src_configure() {
- # mask broken asserts in src/step_vector.h:72
- append-cppflags -DNDEBUG
-
- distutils-r1_src_configure
-}
-
-python_test() {
- distutils_install_for_testing
-
- # Due to the build directories creating a competing
- # hierarchy, we move to the test/ dir to avoid implicitly
- # injecting the root HTSeq/ dir into the PYTHONPATH,
- # which leads the python module lookup astray:
- # ${PWD}
- # ├── build
- # │ ├── lib
- # │ │ └── HTSeq
- # │ [...]
- # ├── HTSeq
- # └── test
- cd test/ || die
- ln -s ../example_data || die
- epytest
-}
diff --git a/sci-biology/HTSeq/Manifest b/sci-biology/HTSeq/Manifest
deleted file mode 100644
index 89b37aa1c25b..000000000000
--- a/sci-biology/HTSeq/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST HTSeq-2.0.2.gh.tar.gz 48468261 BLAKE2B c68ec67906f3cf78954e94214b82fd51bc19e0c505f994a3df4bfc682d804fa26f4883e9a8fa1e8ddf1e4f8ba8690d605705ebdd2d1695470984c2f04b6a19ce SHA512 96c0b4de6c9cfa9e405f02e366ecfed63bb0dba0ab76fe872f6f48b52a4956b08fa75efa4b1e4c6e4560e34b4e2921bf1ec9671831226ad415ed421a88ec3f6d
diff --git a/sci-biology/HTSeq/metadata.xml b/sci-biology/HTSeq/metadata.xml
deleted file mode 100644
index 6ada1a530737..000000000000
--- a/sci-biology/HTSeq/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-biology@gentoo.org</email>
- <name>Gentoo Biology Project</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">HTSeq</remote-id>
- <remote-id type="github">htseq/htseq</remote-id>
- </upstream>
-</pkgmetadata>