summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-03-20 07:45:06 -0500
committerBen Kohler <bkohler@gentoo.org>2020-03-20 07:52:42 -0500
commit4e79cd71a851b3b1954249399a88b05e0429eac4 (patch)
tree07646c9b600730f5c35b15c2c7ff2788346348e7
parentdev-libs/icu-layoutex: 66.1 version bump (diff)
downloadgentoo-4e79cd71a851b3b1954249399a88b05e0429eac4.tar.gz
gentoo-4e79cd71a851b3b1954249399a88b05e0429eac4.tar.bz2
gentoo-4e79cd71a851b3b1954249399a88b05e0429eac4.zip
net-misc/ncman: EAPI=7 & multiple fixes in 9999
1) bump EAPI to 7 2) add musl build workaround 3) rework ebuild to unify with versioned snapshot ebuild Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--net-misc/ncman/ncman-9999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/net-misc/ncman/ncman-9999.ebuild b/net-misc/ncman/ncman-9999.ebuild
index 54dde8ba11c3..e5f04eaaaea0 100644
--- a/net-misc/ncman/ncman-9999.ebuild
+++ b/net-misc/ncman/ncman-9999.ebuild
@@ -1,21 +1,32 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit meson git-r3
-COMMIT="bca0dc0a835f8a267be28d32b49775a50543d081"
+inherit flag-o-matic meson
+COMMIT=""
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
+else
+ SRC_URI="https://github.com/l4rzy/ncman/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
DESCRIPTION="An ncurses UI for connman, forked from connman-json-client"
HOMEPAGE="https://github.com/l4rzy/ncman"
-EGIT_REPO_URI=https://github.com/l4rzy/ncman.git
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE=""
RDEPEND="dev-libs/json-c:0=
>=sys-apps/dbus-1.4
sys-libs/ncurses:0="
DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ append-cflags "-D_POSIX_C_SOURCE=200809L"
+}