summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-05-01 16:23:15 -0400
committerMatt Turner <mattst88@gentoo.org>2024-05-01 16:24:20 -0400
commit4e7eff1ee569cf8268561cac3ac42302e5b02f08 (patch)
tree88213992c9b9c410f7cc7212eecd7fb87171d9f2
parentnet-wireless/kismet: add blocker to prevent protobuf breakage (diff)
downloadgentoo-4e7eff1ee569cf8268561cac3ac42302e5b02f08.tar.gz
gentoo-4e7eff1ee569cf8268561cac3ac42302e5b02f08.tar.bz2
gentoo-4e7eff1ee569cf8268561cac3ac42302e5b02f08.zip
app-shells/fzf: Version bump to 0.51.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.51.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index 61f741ab5780..e969e80e334f 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -4,3 +4,5 @@ DIST fzf-0.46.1-deps.tar.xz 5779780 BLAKE2B ef1364b81c353019b28f097a22a92e8dc641
DIST fzf-0.46.1.tar.gz 258918 BLAKE2B 2beb5c5048ead73cc57c96aab26b9d331299473e0253bab4bc8cf0aea0be547266a0b1bca36aec9968de740e72d41d905eb0256f4690d9a3d55ec1acff5f6bbd SHA512 c2e07be08bc2d93981acfd9857f395e0c803046754d8d61e888fa4dc4d0f6f3d62eb19b518273cce23ae2eeffe68f2ecc692cb09cdcdfc30df9443419e3fc4cb
DIST fzf-0.49.0-deps.tar.xz 17668152 BLAKE2B 3f5c16b10c7605dec7b775df6c5d4e7dca15fa66c02a7fcacab82833ab0c5e86ca4c0ef5e4e40d12503196bca238b1b2bc23cdb964771b7cd810832c1d736211 SHA512 2e6ec8327858ce428ebe2d4288130c871d3bd64fea13bf861e613926b98ff53b4c840f8783f510f7e9ed3f4e121f5e21f49eddfd076296c9208ba87f53bffb40
DIST fzf-0.49.0.tar.gz 264849 BLAKE2B 24a51f49384e2c45746181156de20fdb3c8e31c9b1e9bdc9866ba92f654d66b62e3a29afdce794bb23bba441591ab79737ef05716b34a13a76cce66bf24de02b SHA512 fe9d380e1fba460a45ce70a3b44681454833243881a133108f9087a204b1adaafae7bc13e083d25bc783eedb7d4998d5f2301c87f981c0368d081f7f60107fe8
+DIST fzf-0.51.0-deps.tar.xz 17657716 BLAKE2B edca4dfdd2030bc3dd1564c3eef81d50d219b7c24da195e3cfce7bb079d7ee2676964fbae60f6ec04f46e5bcfc880c524b97c043cc6cfcd2e8e76b967939bb11 SHA512 155a4695c6acf9cff416752c4ed8f6cd3ff00d1ae48e988cd95eb58fd4cb93cc4db2cdb9464d2fa26277fc9fd26584d398f4bd9681e6aee9e68c3039709c0fbe
+DIST fzf-0.51.0.tar.gz 273767 BLAKE2B 96a481ef3e71a201fc94ef554f7aaae80ad62b2961a2403fa1a3c5883d79d9bec61c58c71a205c2d63b78742af23e16a82da91da800482bb8d9c85f6a3b3d149 SHA512 deb9c434764571eeab466898e1c782ff2fdeedc112f449c6d03e42f1b6fd3f8ee3c83252190f099ab030768920148144fb9c73840c6e36d43dad42b004045e65
diff --git a/app-shells/fzf/fzf-0.51.0.ebuild b/app-shells/fzf/fzf-0.51.0.ebuild
new file mode 100644
index 000000000000..29107a6ca464
--- /dev/null
+++ b/app-shells/fzf/fzf-0.51.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=62963dcefd6d74510ae2692cd0955177bae57543
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}