summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 16:28:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 17:42:21 +0200
commit50a8e0e2a36b9b00dc8076834bb21eef814f92f8 (patch)
tree5ed22c4915395cbbe883f7bd922f9a702d20f271
parentdev-python/extras: Port to py39 (diff)
downloadgentoo-50a8e0e2a36b9b00dc8076834bb21eef814f92f8.tar.gz
gentoo-50a8e0e2a36b9b00dc8076834bb21eef814f92f8.tar.bz2
gentoo-50a8e0e2a36b9b00dc8076834bb21eef814f92f8.zip
dev-python/linecache2: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/linecache2/linecache2-1.0.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/linecache2/linecache2-1.0.0.ebuild b/dev-python/linecache2/linecache2-1.0.0.ebuild
index 21d4c0a310d7..0f3e5e0bdcd4 100644
--- a/dev-python/linecache2/linecache2-1.0.0.ebuild
+++ b/dev-python/linecache2/linecache2-1.0.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6..9} pypy3 )
inherit distutils-r1
@@ -17,16 +17,13 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/fixtures[${PYTHON_USEDEP}]
dev-python/unittest2[${PYTHON_USEDEP}]
)"
-RDEPEND=""
-
python_test() {
"${PYTHON}" -m unittest2 discover || die "tests failed under ${EPYTHON}"
}