summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-10 00:13:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-10 00:26:32 +0100
commit5210a456080df3357837c6ca7408b47f5ebfe94b (patch)
tree7f9a1be79059c4c56b977dc60c3ebf8aac08006f
parentdev-cpp/glibmm: add 2.78.1, enable py3.12 (diff)
downloadgentoo-5210a456080df3357837c6ca7408b47f5ebfe94b.tar.gz
gentoo-5210a456080df3357837c6ca7408b47f5ebfe94b.tar.bz2
gentoo-5210a456080df3357837c6ca7408b47f5ebfe94b.zip
kde-plasma/plasma-meta: Add IUSE qt5, webengine
USE=qt5 is currently globally enabled by desktop profiles, its addition here is used to sync down integration USEdeps in the relevant dependencies. Also add a postinst warning coupled with the existence of dev-qt/qtgui. Add IUSE webengine for kde-apps/khelpcenter:6 to avoid dependency on dev-qt/qtwebengine:6. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-meta/metadata.xml2
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-6.0.1-r1.ebuild (renamed from kde-plasma/plasma-meta/plasma-meta-6.0.1.ebuild)27
2 files changed, 21 insertions, 8 deletions
diff --git a/kde-plasma/plasma-meta/metadata.xml b/kde-plasma/plasma-meta/metadata.xml
index 715252bddc69..d99c868979a6 100644
--- a/kde-plasma/plasma-meta/metadata.xml
+++ b/kde-plasma/plasma-meta/metadata.xml
@@ -25,6 +25,7 @@
<flag name="oxygen-theme">Pull in Oxygen icons, sound theme and visual style for KDE Plasma</flag>
<flag name="plymouth">Pull in Breeze theme for <pkg>sys-boot/plymouth</pkg></flag>
<flag name="pulseaudio">Install Plasma applet for PulseAudio volume management</flag>
+ <flag name="qt5">Pull in required packages for seamless integration of KF5/Qt5-based applications</flag>
<flag name="sddm">Pull in the <pkg>x11-misc/sddm</pkg> display manager and system settings module</flag>
<flag name="sdk">Pull in <pkg>kde-plasma/plasma-sdk</pkg> for Plasma development</flag>
<flag name="smart">Pull in <pkg>kde-plasma/plasma-disks</pkg> for disk health monitoring</flag>
@@ -32,6 +33,7 @@
<flag name="unsupported">Allow packages that are known to ruin runtime experience ** DO NOT FILE BUGS WITH THIS ENABLED **</flag>
<flag name="wacom">Pull in <pkg>kde-plasma/wacomtablet</pkg> control center module</flag>
<flag name="wallpapers">Install wallpapers for the Plasma Workspace</flag>
+ <flag name="webengine">Use <pkg>kde-apps/khelpcenter</pkg> to access the locally installed KDE Help System Handbook</flag>
<flag name="xwayland">Enable Wayland windows screensharing to XWayland applications via <pkg>gui-apps/xwaylandvideobridge</pkg></flag>
</use>
</pkgmetadata>
diff --git a/kde-plasma/plasma-meta/plasma-meta-6.0.1.ebuild b/kde-plasma/plasma-meta/plasma-meta-6.0.1-r1.ebuild
index cbd2949a4727..e38e671c9a36 100644
--- a/kde-plasma/plasma-meta/plasma-meta-6.0.1.ebuild
+++ b/kde-plasma/plasma-meta/plasma-meta-6.0.1-r1.ebuild
@@ -10,15 +10,15 @@ LICENSE="metapackage"
SLOT="6"
KEYWORDS="~amd64"
IUSE="accessibility bluetooth +browser-integration colord +crash-handler crypt
-cups discover +display-manager +elogind +firewall flatpak grub gtk +handbook
-+kwallet +networkmanager oxygen-theme plymouth pulseaudio +sddm sdk +smart
-systemd thunderbolt unsupported wacom +wallpapers +xwayland"
+cups discover +display-manager +elogind +firewall flatpak grub gtk +kwallet
++networkmanager oxygen-theme plymouth pulseaudio qt5 +sddm sdk +smart systemd
+thunderbolt unsupported wacom +wallpapers webengine +xwayland"
REQUIRED_USE="^^ ( elogind systemd )"
RDEPEND="
!${CATEGORY}/${PN}:5
- >=kde-plasma/breeze-${PV}:${SLOT}
+ >=kde-plasma/breeze-${PV}:${SLOT}[qt5?]
>=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
>=kde-plasma/kde-cli-tools-${PV}:${SLOT}
>=kde-plasma/kdecoration-${PV}:${SLOT}
@@ -33,7 +33,6 @@ RDEPEND="
>=kde-plasma/ksshaskpass-${PV}:${SLOT}
>=kde-plasma/ksystemstats-${PV}:${SLOT}
>=kde-plasma/kwayland-${PV}:${SLOT}
- >=kde-plasma/kwayland-integration-${PV}:5
>=kde-plasma/kwin-${PV}:${SLOT}[lock]
>=kde-plasma/kwrited-${PV}:${SLOT}
>=kde-plasma/layer-shell-qt-${PV}:${SLOT}
@@ -45,7 +44,7 @@ RDEPEND="
>=kde-plasma/plasma-activities-${PV}:${SLOT}
>=kde-plasma/plasma-activities-stats-${PV}:${SLOT}
>=kde-plasma/plasma-desktop-${PV}:${SLOT}
- >=kde-plasma/plasma-integration-${PV}:${SLOT}
+ >=kde-plasma/plasma-integration-${PV}:${SLOT}[qt5?]
>=kde-plasma/plasma-systemmonitor-${PV}:${SLOT}
>=kde-plasma/plasma-welcome-${PV}:${SLOT}
>=kde-plasma/plasma-workspace-${PV}:${SLOT}
@@ -80,7 +79,6 @@ RDEPEND="
>=kde-plasma/kde-gtk-config-${PV}:${SLOT}
x11-misc/appmenu-gtk-module
)
- handbook? ( kde-apps/khelpcenter:* )
kwallet? ( >=kde-plasma/kwallet-pam-${PV}:${SLOT} )
networkmanager? (
>=kde-plasma/plasma-nm-${PV}:${SLOT}
@@ -88,7 +86,7 @@ RDEPEND="
)
oxygen-theme? (
>=kde-frameworks/oxygen-icons-6.0.0:*
- >=kde-plasma/oxygen-${PV}:${SLOT}
+ >=kde-plasma/oxygen-${PV}:${SLOT}[qt5?]
>=kde-plasma/oxygen-sounds-${PV}:${SLOT}
)
plymouth? (
@@ -96,6 +94,7 @@ RDEPEND="
>=kde-plasma/plymouth-kcm-${PV}:${SLOT}
)
pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
+ qt5? ( >=kde-plasma/kwayland-integration-${PV}:5 )
sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
smart? ( >=kde-plasma/plasma-disks-${PV}:${SLOT} )
systemd? (
@@ -109,9 +108,21 @@ RDEPEND="
)
wacom? ( >=kde-plasma/wacomtablet-${PV}:${SLOT} )
wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
+ webengine? ( kde-apps/khelpcenter:6 )
xwayland? ( >=gui-apps/xwaylandvideobridge-0.4.0 )
"
# Optional runtime deps: kde-plasma/plasma-desktop
RDEPEND="${RDEPEND}
accessibility? ( app-accessibility/orca )
"
+
+pkg_postinst() {
+ if ! use qt5 && has_version dev-qt/qtgui; then
+ ewarn "KF5- and Qt5-based applications will exhibit various integration bugs"
+ ewarn "and generally look out of place in Plasma 6 without the dependencies"
+ ewarn "enforced by kde-plasma/plasma-meta[qt5]."
+ ewarn
+ ewarn "This warning message is being displayed because dev-qt/qtgui:5 is"
+ ewarn "currently installed which indicates the use of such applications."
+ fi
+}