summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 15:16:01 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 15:16:01 +0200
commit52fc6e9547d84e09c0e13658617c46ceab10d3a1 (patch)
tree1b4b03e4ccb6bbe7ba1d9960c2281b892f2d4ec4
parentsci-biology/HTSeq: add 2.0.2 (diff)
downloadgentoo-52fc6e9547d84e09c0e13658617c46ceab10d3a1.tar.gz
gentoo-52fc6e9547d84e09c0e13658617c46ceab10d3a1.tar.bz2
gentoo-52fc6e9547d84e09c0e13658617c46ceab10d3a1.zip
sci-biology/HTSeq: sync live ebuild
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-biology/HTSeq/HTSeq-9999.ebuild49
1 files changed, 42 insertions, 7 deletions
diff --git a/sci-biology/HTSeq/HTSeq-9999.ebuild b/sci-biology/HTSeq/HTSeq-9999.ebuild
index 548684fd531b..678968788ff7 100644
--- a/sci-biology/HTSeq/HTSeq-9999.ebuild
+++ b/sci-biology/HTSeq/HTSeq-9999.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
+inherit distutils-r1 flag-o-matic
DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
HOMEPAGE="https://htseq.readthedocs.io/"
@@ -14,7 +15,7 @@ if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/htseq/htseq.git"
else
- SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/htseq/htseq/archive/release_${PV}.tar.gz -> ${P}.gh.tar.gz"
S="${WORKDIR}"/htseq-release_${PV}
KEYWORDS="~amd64"
@@ -22,12 +23,46 @@ fi
LICENSE="GPL-3+"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
sci-biology/pysam[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
BDEPEND="
>=dev-lang/swig-3.0.8
dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # mask broken asserts in src/step_vector.h:72
+ append-cppflags -DNDEBUG
+
+ distutils-r1_src_configure
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ # Due to the build directories creating a competing
+ # hierarchy, we move to the test/ dir to avoid implicitly
+ # injecting the root HTSeq/ dir into the PYTHONPATH,
+ # which leads the python module lookup astray:
+ # ${PWD}
+ # ├── build
+ # │ ├── lib
+ # │ │ └── HTSeq
+ # │ [...]
+ # ├── HTSeq
+ # └── test
+ cd test/ || die
+ ln -s ../example_data || die
+ epytest
+}