summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-03-18 16:52:25 +0100
committerSam James <sam@gentoo.org>2023-03-25 04:05:36 +0000
commit5325e7d3d1a5b9561fb03b3b6a55bc88db3c8a94 (patch)
treef0c6fd54de454784b64f15b837e1da24f5029cd4
parentsys-devel/gdb: add 13.1.90_p20230325 (diff)
downloadgentoo-5325e7d3d1a5b9561fb03b3b6a55bc88db3c8a94.tar.gz
gentoo-5325e7d3d1a5b9561fb03b3b6a55bc88db3c8a94.tar.bz2
gentoo-5325e7d3d1a5b9561fb03b3b6a55bc88db3c8a94.zip
dev-util/codespell: add 2.2.4
Closes: https://bugs.gentoo.org/901199 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/codespell/Manifest1
-rw-r--r--dev-util/codespell/codespell-2.2.4.ebuild23
-rw-r--r--dev-util/codespell/files/codespell-2.2.4-drop-coverage.patch17
-rw-r--r--dev-util/codespell/metadata.xml1
4 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/codespell/Manifest b/dev-util/codespell/Manifest
index 279d8d249dc7..ef9e449358ce 100644
--- a/dev-util/codespell/Manifest
+++ b/dev-util/codespell/Manifest
@@ -1,2 +1,3 @@
DIST codespell-2.2.1.tar.gz 211593 BLAKE2B aba431119fd1f16ee51076cd4496ef3f3e80e56a124bbbd4ebbec5dcee5b7e49788db37bcdefd15946d12680596b33ab20ae845fd9a3a3a61ee8c3eed187fe2f SHA512 6c1ce9ed134ba4602cc91c1851a023911ff09ce7d4b1e8a33e655bf821a5b82ae8f0e75defef43e9a8537a6ffc7f0ad7e59af7b200a1294dfe3aff1651869e41
DIST codespell-2.2.2.tar.gz 213652 BLAKE2B 2084f6041c6cf9888b661a1b7b8a73696b1dc6309b8d19adbb0dbdc091d87b487464b12c9800cfec893ed5d6ea71f214d0a4262099617b5fe7e60d8ca448973d SHA512 48be00aa32e55a66814193014e97fcb27ff323ea2db0622f68cd2d3ab31ab8be61f60a09ed91fe3425cbd63b2592bcc44ee9b58fe79e2d498bc27a83a4e93ddd
+DIST codespell-2.2.4.tar.gz 241664 BLAKE2B 5f40003fdb840b926615b6eed74df90055b2ee47c534321289c3ed895c47cd2672909b152a53640899cc21960c1b3aa80c41eb344d9e23cea8fd13e998c71af6 SHA512 efbc62a3dd49781565f6d901aa9b08fc1106adf2c516365dd8d3684846e23b23bfda1e65c6530edf0de9462ccafd9d835bd541a8f0e1de14163c723ce041052d
diff --git a/dev-util/codespell/codespell-2.2.4.ebuild b/dev-util/codespell/codespell-2.2.4.ebuild
new file mode 100644
index 000000000000..f2af4c1fbbbc
--- /dev/null
+++ b/dev-util/codespell/codespell-2.2.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Check text files for common misspellings"
+HOMEPAGE="https://pypi.org/project/codespell https://github.com/codespell-project/codespell"
+
+# Code licensed under GPL-2, dictionary licensed under CC-BY-SA-3.0
+LICENSE="GPL-2 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2.4-drop-coverage.patch )
+
+distutils_enable_tests pytest
diff --git a/dev-util/codespell/files/codespell-2.2.4-drop-coverage.patch b/dev-util/codespell/files/codespell-2.2.4-drop-coverage.patch
new file mode 100644
index 000000000000..beedf8f6d3fb
--- /dev/null
+++ b/dev-util/codespell/files/codespell-2.2.4-drop-coverage.patch
@@ -0,0 +1,17 @@
+From c032b3e7c251343826c1f199b7a1e4c097f79314 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 18 Mar 2023 16:45:57 +0100
+Subject: [PATCH] drop coverage
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -151,4 +151,4 @@ good-names=["F","r","i","n"]
+ # include-naming-hint=yes
+
+ [tool.pytest.ini_options]
+-addopts = "--cov=codespell_lib -rs --cov-report= --tb=short --junit-xml=junit-results.xml"
++addopts = "-rs --tb=short --junit-xml=junit-results.xml"
+--
+2.40.0
+
diff --git a/dev-util/codespell/metadata.xml b/dev-util/codespell/metadata.xml
index d62288ef36d1..d8af0e50ae07 100644
--- a/dev-util/codespell/metadata.xml
+++ b/dev-util/codespell/metadata.xml
@@ -16,6 +16,7 @@
</longdescription>
<upstream>
<bugs-to>https://github.com/codespell-project/codespell/issues</bugs-to>
+ <remote-id type="pypi">codespell</remote-id>
<remote-id type="github">codespell-project/codespell</remote-id>
</upstream>
</pkgmetadata>