summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:16:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:16:44 +0200
commit5359f5af57ac2a2837757c9b19a665d61af7bc2a (patch)
tree17ba0d8f89fc7f3ab9c064d3b9d130dd269fec54
parentdev-ros/gazebo_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-5359f5af57ac2a2837757c9b19a665d61af7bc2a.tar.gz
gentoo-5359f5af57ac2a2837757c9b19a665d61af7bc2a.tar.bz2
gentoo-5359f5af57ac2a2837757c9b19a665d61af7bc2a.zip
dev-ros/object_recognition_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/object_recognition_msgs/Manifest1
-rw-r--r--dev-ros/object_recognition_msgs/metadata.xml5
-rw-r--r--dev-ros/object_recognition_msgs/object_recognition_msgs-0.4.1.ebuild27
-rw-r--r--dev-ros/object_recognition_msgs/object_recognition_msgs-9999.ebuild27
4 files changed, 60 insertions, 0 deletions
diff --git a/dev-ros/object_recognition_msgs/Manifest b/dev-ros/object_recognition_msgs/Manifest
new file mode 100644
index 000000000000..d16ebb140a9c
--- /dev/null
+++ b/dev-ros/object_recognition_msgs/Manifest
@@ -0,0 +1 @@
+DIST object_recognition_msgs-0.4.1.tar.gz 4756 SHA256 b7689a079ad78a4358946fa5a38de0c9a5c12e46381d22106f053ac5cde357f1 SHA512 4e2d48795b0376640dbb6eb82ca3d0cdf5e2d4a2e7ec8d723ce7613c678fc2dc037fceafe8b37a905d9bb2f0a283e84e4adbf986dd6e5322ae96d43de120a3cf WHIRLPOOL 6c30dfe2ef30bd2b90b2b686e4569e89e3c1e0a50f3c34370bd62a1a0572ab8916831e8c1bce3518e9bdf174ff6a68550d934c9d620d3ac5aa5295852a67fc4e
diff --git a/dev-ros/object_recognition_msgs/metadata.xml b/dev-ros/object_recognition_msgs/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/object_recognition_msgs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/object_recognition_msgs/object_recognition_msgs-0.4.1.ebuild b/dev-ros/object_recognition_msgs/object_recognition_msgs-0.4.1.ebuild
new file mode 100644
index 000000000000..8aa6ad80bc4b
--- /dev/null
+++ b/dev-ros/object_recognition_msgs/object_recognition_msgs-0.4.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/wg-perception/object_recognition_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/geometry_msgs
+ dev-ros/sensor_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS message and the actionlib definition used in object_recognition_core"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/object_recognition_msgs/object_recognition_msgs-9999.ebuild b/dev-ros/object_recognition_msgs/object_recognition_msgs-9999.ebuild
new file mode 100644
index 000000000000..8aa6ad80bc4b
--- /dev/null
+++ b/dev-ros/object_recognition_msgs/object_recognition_msgs-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/wg-perception/object_recognition_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="
+ dev-ros/actionlib_msgs
+ dev-ros/geometry_msgs
+ dev-ros/sensor_msgs
+ dev-ros/shape_msgs
+ dev-ros/std_msgs
+"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS message and the actionlib definition used in object_recognition_core"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"