summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-07-15 03:36:45 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-07-15 04:07:05 -0500
commit539e82b485a80fe6c8685e5997e60c610660f89f (patch)
treebb95092ef8406bef6d72726640bfeb7e778b8cc8
parentsci-libs/libsc: try to avoid a performance regression with 2.8.5 (diff)
downloadgentoo-539e82b485a80fe6c8685e5997e60c610660f89f.tar.gz
gentoo-539e82b485a80fe6c8685e5997e60c610660f89f.tar.bz2
gentoo-539e82b485a80fe6c8685e5997e60c610660f89f.zip
sci-libs/p4est: try to avoid a performance regression with 2.8.5
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--sci-libs/p4est/p4est-2.8.5-r3.ebuild (renamed from sci-libs/p4est/p4est-2.8.5-r2.ebuild)4
1 files changed, 4 insertions, 0 deletions
diff --git a/sci-libs/p4est/p4est-2.8.5-r2.ebuild b/sci-libs/p4est/p4est-2.8.5-r3.ebuild
index 3bcba02fb697..253f6ee31911 100644
--- a/sci-libs/p4est/p4est-2.8.5-r2.ebuild
+++ b/sci-libs/p4est/p4est-2.8.5-r3.ebuild
@@ -50,6 +50,10 @@ pkg_setup() {
}
src_configure() {
+ # avoid using debug codepaths that are manually enabled with the
+ # RelWithDebInfo build type
+ local CMAKE_BUILD_TYPE="Release"
+
local mycmakeargs=(
-Dmpi="$(usex mpi)"
-Dopenmp="$(usex openmp)"