summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 14:30:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 14:37:08 +0200
commit5511b909d09df61464ff3552ea4156ea9c111cc5 (patch)
tree908256450a7a8eeb117e17cd3b2148c12dcea2f5
parentdev-python/types-docutils: Remove old (diff)
downloadgentoo-5511b909d09df61464ff3552ea4156ea9c111cc5.tar.gz
gentoo-5511b909d09df61464ff3552ea4156ea9c111cc5.tar.bz2
gentoo-5511b909d09df61464ff3552ea4156ea9c111cc5.zip
dev-python/pytest-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-mock/Manifest1
-rw-r--r--dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch34
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.12.0.ebuild59
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index ae7dceabba56..3f7cb9be9fbf 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,2 +1 @@
-DIST pytest-mock-3.12.0.tar.gz 32139 BLAKE2B 4bc2289579686b8ca9e840440b21b7299817e803f108726692cda6f1a138564462b04b9ae6a3038a5e36ec4d665bb7c8f54c26d231d6b17188b8d830d553b20d SHA512 6da429e646a4e3a825f699969dbc87033136918bd9aa111ff334fac324e5ac89ef6516e82ffeeb20cb6a857fbbe904d8ee985acefba2d2b7bd0ffe4b9227ad82
DIST pytest-mock-3.14.0.tar.gz 32814 BLAKE2B f6e10dd6781bf10076c7c42f9cfc8cd4e4cfd3aa08030c9ad6377ee64b3386ddd190eac8bd1a912d54b5ef4aba14dfe136b3968b6ed08683dd4c4f102eaf8a26 SHA512 c60059fe8fb64540f33382e52b9015dd9771483e2074d35c02cd5852a50eed02a64e202b7e81e920bbbd0621bd23fa9bb0467d2ceef7abd582df3e27eafeaa20
diff --git a/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch b/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch
deleted file mode 100644
index e3938fb1457c..000000000000
--- a/dev-python/pytest-mock/files/pytest-mock-3.12.0-test.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 39547ecdc051123750dd17a890c0492ac5d5b1a0 Mon Sep 17 00:00:00 2001
-From: Daniel Garcia Moreno <daniel.garcia@suse.com>
-Date: Wed, 20 Dec 2023 13:39:14 +0100
-Subject: [PATCH] Update expected message to match python 3.11.7
-
-https://github.com/python/cpython/issues/111019
----
- tests/test_pytest_mock.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py
-index c185f2a..01534a4 100644
---- a/tests/test_pytest_mock.py
-+++ b/tests/test_pytest_mock.py
-@@ -25,6 +25,8 @@
-
- # Python 3.8 changed the output formatting (bpo-35500), which has been ported to mock 3.0
- NEW_FORMATTING = sys.version_info >= (3, 8)
-+# Python 3.11.7 changed the output formatting, https://github.com/python/cpython/issues/111019
-+NEWEST_FORMATTING = sys.version_info >= (3, 11, 7)
-
- if sys.version_info[:2] >= (3, 8):
- from unittest.mock import AsyncMock
-@@ -240,7 +242,9 @@ def test_repr_with_name(self, mocker: MockerFixture) -> None:
-
- def __test_failure_message(self, mocker: MockerFixture, **kwargs: Any) -> None:
- expected_name = kwargs.get("name") or "mock"
-- if NEW_FORMATTING:
-+ if NEWEST_FORMATTING:
-+ msg = "expected call not found.\nExpected: {0}()\n Actual: not called."
-+ elif NEW_FORMATTING:
- msg = "expected call not found.\nExpected: {0}()\nActual: not called."
- else:
- msg = "Expected call: {0}()\nNot called"
diff --git a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
deleted file mode 100644
index ccb417b563d1..000000000000
--- a/dev-python/pytest-mock/pytest-mock-3.12.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_TESTED=( python3_{10..12} pypy3 )
-PYTHON_COMPAT=( "${PYTHON_TESTED[@]}" )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="
- https://github.com/pytest-dev/pytest-mock/
- https://pypi.org/project/pytest-mock/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- ' "${PYTHON_TESTED[@]}")
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/pytest-dev/pytest-mock/pull/404
- "${FILESDIR}/${P}-test.patch"
-)
-
-python_test() {
- if ! has "${EPYTHON/./_}" "${PYTHON_TESTED[@]}"; then
- einfo "Skipping tests on ${EPYTHON}"
- return
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
- local EPYTEST_DESELECT=()
-
- if has_version dev-python/mock; then
- EPYTEST_DESELECT+=(
- tests/test_pytest_mock.py::test_standalone_mock
- )
- fi
-
- epytest --assert=plain
-}