summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-02 08:05:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-02 09:05:02 -0400
commit553144f704b958563a1c109b65e5b7d4645489ee (patch)
tree50251654443ea85d99a3983802d7fb35b236b8d0
parentdev-qt/qthttpserver: add 6.7.0 (diff)
downloadgentoo-553144f704b958563a1c109b65e5b7d4645489ee.tar.gz
gentoo-553144f704b958563a1c109b65e5b7d4645489ee.tar.bz2
gentoo-553144f704b958563a1c109b65e5b7d4645489ee.zip
dev-qt/qtimageformats: add 6.7.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtimageformats/Manifest1
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.7.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index 638b8ab911ee..8a483c156eaa 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -4,3 +4,4 @@ DIST qtimageformats-everywhere-opensource-src-5.15.12.tar.xz 1865016 BLAKE2B 74d
DIST qtimageformats-everywhere-opensource-src-5.15.13.tar.xz 1888944 BLAKE2B ff71d92749691bcf79622b7a8e9873c7f7b44e01a88365d4b86f627164c26060f582442c9a11de1ad627a15c7da8cdfbca7ec0e1a5ffb30aa295a329331a6d3a SHA512 48b0dac1acfdae1b090bc5d0054610f61290135363400a629ce3650cddd4c11f7bd95edd5bd1d36d758006a5fd54ded29f540a6e8dc675ca2e85d4ae169add50
DIST qtimageformats-everywhere-src-6.6.2.tar.xz 1964116 BLAKE2B 1fe0c428dd9602d7b9abd7e2cfdda8f179511c912fcf4f501400619ac91a5cde6b57f8f38c6c1d22a1efd6fc285b49cbf2ee23132faea516c55f552819ea0850 SHA512 64704becdd6f1a50f4a4c0edabc6be2f8a114c978728a62b2a5c9502e2457699f6e86135146c56afef715f865dd1c10062cf485ad97c890884bace8a163c24a5
DIST qtimageformats-everywhere-src-6.6.3.tar.xz 1964752 BLAKE2B b1984e84747e609f5ab7bb2c3b9c3b6e14c4e57bf48a9a4d42dad79f216e6f16631c7049127fd04ff1d761b2c3972b4421b2f360c883b0597071a3e2c0355753 SHA512 4fe56a787742f4af5e3e5c41c8c7850190bacea6a6d13ccde4ce299dbd15d2a1ab8b1825353ad324ca159333c0adc5dede823e79e217de3ab5910c5803b96d6d
+DIST qtimageformats-everywhere-src-6.7.0.tar.xz 1968344 BLAKE2B b0d91c5a8d902ac2c4afd285d27adf5cde3af05607333606a4721b1622e1eac87bc58d1452ae3e38684a35ec921b023d2101f9f47a19a7701d72d0cfb62cefbf SHA512 0e30021b028a4e6754c300d343aa72f93ab855cba043ddb2d24855989823c82c78ea67871399d78105dbc092abe2666e0a92caa50aa780ca4e267bf6f05bd914
diff --git a/dev-qt/qtimageformats/qtimageformats-6.7.0.ebuild b/dev-qt/qtimageformats/qtimageformats-6.7.0.ebuild
new file mode 100644
index 000000000000..9d1a9a6f9685
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-6.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc64 ~riscv ~x86"
+fi
+
+IUSE="mng"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # heif plugin is only for Mac, test is normally auto-skipped but may
+ # misbehave with kde-frameworks/kimageformats:6[heif] (bug #927971)
+ tst_qheif
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_jasper=OFF
+ $(qt_feature mng)
+ -DQT_FEATURE_tiff=ON
+ -DQT_FEATURE_webp=ON
+ -DQT_FEATURE_system_tiff=ON
+ -DQT_FEATURE_system_webp=ON
+ )
+
+ qt6-build_src_configure
+}