summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-12-24 17:33:57 +0300
committerSam James <sam@gentoo.org>2022-12-27 10:21:45 +0000
commit5718e87e3541bf83c9f8864a0a7e4fa230255eb3 (patch)
treec6de8d1a446f91301cf4c01701a65ce4be49eab9
parentdev-python/pefile: remove dependency to dev-python/future (diff)
downloadgentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.tar.gz
gentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.tar.bz2
gentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.zip
dev-util/lttng-modules: add 2.13.7
Closes: https://bugs.gentoo.org/852305 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28783 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/lttng-modules/Manifest1
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.13.7.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/Manifest b/dev-util/lttng-modules/Manifest
index 750eaaefc1a8..f35ad1689352 100644
--- a/dev-util/lttng-modules/Manifest
+++ b/dev-util/lttng-modules/Manifest
@@ -2,3 +2,4 @@ DIST lttng-modules-2.12.5.tar.bz2 317002 BLAKE2B 9f42f8641dca7ce55e7445495c747ce
DIST lttng-modules-2.12.6.tar.bz2 318479 BLAKE2B 7cac6dd7dcb12801a32179ced4bb141a7af87c864eb71b793e65b905e4a0ba3d3273609bd3cd80c9c1251914a39e62da0a85e18058480da0c4eb2d6eb44f851c SHA512 608112b960d47ed5f979c7f2de2886d3fbe78a0d2eaec0892bfbca92bdad423e8ba8c3960836f71045c79d9c1b9eac88757400726656e98fb0ae70035e0073aa
DIST lttng-modules-2.12.8.tar.bz2 319450 BLAKE2B 0ce5c6675598c1a4b6fbc0dfaf51d36638f12fe2e07095c37a811db8d7ee65bb242164cf02b1854c27b6894f0b4c73867e8ee1b80dd007290e0db203ea429f9e SHA512 5918a54d08a12cec567cdad2909846ba529d5e665a3592a69384d9546f6f3e23e7975876fc11feaef65604d36889b0598b1cf7b5f2badb4e2b11b255a2e7ca99
DIST lttng-modules-2.13.3.tar.bz2 343593 BLAKE2B a0c914af0118327cb6d785c7c018d2d9cbd2139bbc3e0524a9c96832c7214fea7fc2a0dd8a8770db0728aba6ca3e9f30ea6e790575fb4d3492d9a7485993f293 SHA512 a0329c4709cc1a5fcc8d667d7435bc57b37cfa95da5451a8ee6ab700f334365e2d78e085e537376948dfe95d433016be5f6e3b5e5aa34a05948d4fa42f9102a1
+DIST lttng-modules-2.13.7.tar.bz2 348121 BLAKE2B 880ad964477de6c27675bf5dfbbf131fd7e0fd9e911a1314d08e7aa0307a6eb691a7c09e3d450ac8da5d0bdcb3973396322a72461bf3c9b6ef07f71ad0ba3b83 SHA512 60515e847389ce70f9d0dbc28e73d8a072ea6f509f8c5f7bcf35258d6fda68ddc1e195ac75d4cf24d9535fbe385367644afc37f2a42f0e50ee7b4adfbbb1b4dd
diff --git a/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild b/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild
new file mode 100644
index 000000000000..de25ec1df638
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 3 0; then
+ eerror "${PN} require Linux kernel >= 3.0"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md
+}