summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-05-18 19:06:31 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-07 14:05:05 +0300
commit5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c (patch)
tree6926a44f0dd91922259ea52f32594b06694c0ca8
parentwww-client/surf: update live (diff)
downloadgentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.tar.gz
gentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.tar.bz2
gentoo-5a200bbbdf0dec57be5b2b5aa50e2acbf130ab9c.zip
www-client/surf: add 2.1
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--www-client/surf/Manifest1
-rw-r--r--www-client/surf/files/surf-2.1-gentoo.patch (renamed from www-client/surf/files/surf-9999-gentoo.patch)2
-rw-r--r--www-client/surf/surf-2.1.ebuild76
-rw-r--r--www-client/surf/surf-9999.ebuild2
4 files changed, 79 insertions, 2 deletions
diff --git a/www-client/surf/Manifest b/www-client/surf/Manifest
index 85373d1ede51..3d1984435d02 100644
--- a/www-client/surf/Manifest
+++ b/www-client/surf/Manifest
@@ -1 +1,2 @@
DIST surf-2.0.tar.gz 19056 BLAKE2B d9ef974ec14ce1ddf2437a43ccb0f424ada75d64ce926b19ac56f072d3589e6d251220842372f100f835ffbcccea2c402306a0c9f19f25462f5cb69fe4d7d175 SHA512 75798bb189fa2c2c93827672089a86cf155aa7b5c7c1a0887a34817ca41763907e44a02f52947535d37a043f827d2c0fe75d16a3d172079f9cab8da341e4c0c5
+DIST surf-2.1.tar.gz 22555 BLAKE2B 3170b0b26893361ec84f2552051dc85b4a6fc132ff09a2dc2e9256f8ec8cdf93650c41b4d0466ebb5b608e2bde9282c1d1f64bb6f17114c58da7616994473f22 SHA512 06f31f683a941d9a587d908ae7f6949255937b0b0c9c133a18c6fa753c7da75de267adda1c83dd9ba0a8535e2b6d4ff2b5408cc5e8a2e315d4198fe68df5db12
diff --git a/www-client/surf/files/surf-9999-gentoo.patch b/www-client/surf/files/surf-2.1-gentoo.patch
index fe6324ddbc9f..9ef89da23668 100644
--- a/www-client/surf/files/surf-9999-gentoo.patch
+++ b/www-client/surf/files/surf-2.1-gentoo.patch
@@ -1,6 +1,6 @@
--- a/config.mk
+++ b/config.mk
-@@ -4,18 +4,18 @@ VERSION = 2.0
+@@ -4,18 +4,18 @@ VERSION = 2.1
# Customize below to fit your system
# paths
diff --git a/www-client/surf/surf-2.1.ebuild b/www-client/surf/surf-2.1.ebuild
new file mode 100644
index 000000000000..15922a19958a
--- /dev/null
+++ b/www-client/surf/surf-2.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a simple web browser based on WebKit/GTK+"
+HOMEPAGE="https://surf.suckless.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.suckless.org/surf"
+ EGIT_BRANCH="surf-webkit2"
+else
+ SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="tabbed"
+
+DEPEND="
+ app-crypt/gcr[gtk]
+ dev-libs/glib:2
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ !sci-chemistry/surf
+ !savedconfig? (
+ net-misc/curl
+ x11-apps/xprop
+ x11-misc/dmenu
+ x11-terms/st
+ )
+ tabbed? ( x11-misc/tabbed )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+pkg_setup() {
+ if ! use savedconfig; then
+ elog "The default config.h assumes you have"
+ elog " net-misc/curl"
+ elog " x11-terms/st"
+ elog "installed to support the download function."
+ elog "Without those, downloads will fail (gracefully)."
+ elog "You can fix this by:"
+ elog "1) Installing these packages, or"
+ elog "2) Setting USE=savedconfig and changing config.h accordingly."
+ fi
+}
+
+src_prepare() {
+ default
+
+ restore_config config.h
+
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ default
+
+ if use tabbed; then
+ dobin surf-open.sh
+ fi
+
+ save_config config.h
+}
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index 19c3211f6090..2b48a07f1c22 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -41,7 +41,7 @@ BDEPEND="
virtual/pkgconfig
"
PATCHES=(
- "${FILESDIR}"/${PN}-9999-gentoo.patch
+ "${FILESDIR}"/${PN}-2.1-gentoo.patch
)
pkg_setup() {