summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-28 06:48:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-28 06:48:23 +0200
commit5a4b036cd9d69fa8c310e99e47f199764c078f20 (patch)
tree71f62901d78f4237bbf1a925b68989e67cee53fe
parentdev-python/pypdf: Bump to 3.11.1 (diff)
downloadgentoo-5a4b036cd9d69fa8c310e99e47f199764c078f20.tar.gz
gentoo-5a4b036cd9d69fa8c310e99e47f199764c078f20.tar.bz2
gentoo-5a4b036cd9d69fa8c310e99e47f199764c078f20.zip
dev-python/ConfigArgParse: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ConfigArgParse/ConfigArgParse-1.5.5.ebuild35
-rw-r--r--dev-python/ConfigArgParse/Manifest1
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/ConfigArgParse/ConfigArgParse-1.5.5.ebuild b/dev-python/ConfigArgParse/ConfigArgParse-1.5.5.ebuild
new file mode 100644
index 000000000000..25887a58a083
--- /dev/null
+++ b/dev-python/ConfigArgParse/ConfigArgParse-1.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Drop-in replacement for argparse supporting config files and env variables"
+HOMEPAGE="
+ https://github.com/bw2/ConfigArgParse/
+ https://pypi.org/project/ConfigArgParse/"
+SRC_URI="
+ https://github.com/bw2/ConfigArgParse/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}
diff --git a/dev-python/ConfigArgParse/Manifest b/dev-python/ConfigArgParse/Manifest
index 6e371ece30a4..aad81b8fb6d1 100644
--- a/dev-python/ConfigArgParse/Manifest
+++ b/dev-python/ConfigArgParse/Manifest
@@ -1 +1,2 @@
DIST ConfigArgParse-1.5.3.gh.tar.gz 32732 BLAKE2B a9dec6b3ebbb7aed000651adf76ac76994b56d00236789a75f7da6ccc76e6b87e0dd292c260a768c0d402811b69e55d417b25032363429535cef4e09e0be5d00 SHA512 bdc0340bd92cfd5319743a4860af80fc2352f38b156031856c2b39b8c8ad59461281009030c4451dd464334a829b8143c765979cfc9b8ccbe9fbdcb0e08ac7b4
+DIST ConfigArgParse-1.5.5.gh.tar.gz 37249 BLAKE2B 22eb4e0903e6eaada50782fe68ed8f19ef20685d3d1ea7fcb103cebd75f7cc16db53b89696e35f7ac902061b9a71646c04da79347b66c2557924b70dd38eef66 SHA512 fc9229d12fcc8da3b001d75d10829e1eef4ec0624b89ad319e840bea9a795d3d575a3760538f13a30bd1e778a27a7620486d7cb199fff9df5535017a7fef4a4c