summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-25 04:54:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-25 05:08:44 +0200
commit5ac1ecd434bb5a7ce1ededae5536b13d627f49f2 (patch)
tree3c799ebad3d9f025c57e1aeb154b513677a443da
parentdev-python/keyring: Bump to 24.2.0 (diff)
downloadgentoo-5ac1ecd434bb5a7ce1ededae5536b13d627f49f2.tar.gz
gentoo-5ac1ecd434bb5a7ce1ededae5536b13d627f49f2.tar.bz2
gentoo-5ac1ecd434bb5a7ce1ededae5536b13d627f49f2.zip
dev-python/spyder-line-profiler: Bump to 0.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/spyder-line-profiler/Manifest1
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
index 80567234d77f..ffe9ff515b18 100644
--- a/dev-python/spyder-line-profiler/Manifest
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -1 +1,2 @@
DIST spyder-line-profiler-0.3.1.gh.tar.gz 44042 BLAKE2B a98c5770b44b3e11d2261b371e5a806087ebcb347b54745b5bdfe5c4fe3051ff862c79e96ab9a0048e83217cba65fd48a6368bf3e1d1a3f9ab09d2dd69f8ec7c SHA512 96ddc1817adfd58362ea766b95cd58ad521c1333a6bafe9fef1e117ef7ef602bc7e7bced3990d19b85c2882253d81d27940ab409a9daacf588513a405ae4d8fb
+DIST spyder-line-profiler-0.3.2.gh.tar.gz 88725 BLAKE2B 9e15a9b88d1b36a39428e7eccafb7a2c3d3609aece2c6e5c2f379c9f9180093863472bd1e071b12bf313e7cb6ccd4993bb407785716cab2dda871a1ebd527d41 SHA512 fb2e86cc640c7cd32567852063845567634e7cec365f7f5f5f3d770316b9adabc0447d3ad8334411fe3894aeb086cde4f14b77fd3483c099296db7df15f0b46b
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
new file mode 100644
index 000000000000..b67f71095543
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="
+ https://github.com/spyder-ide/spyder-line-profiler/
+ https://pypi.org/project/spyder-line-profiler/
+"
+SRC_URI="
+ https://github.com/spyder-ide/spyder-line-profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ dev-python/qtawesome[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.2.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-6.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}