summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-12 09:54:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-12 09:54:29 +0200
commit5b6549e04a6ee0edac7d182caba010991c35007d (patch)
treeef023f13157ff3a2e100a012623a064896f9f39a
parentmedia-libs/harfbuzz: Bump to version 1.8.3 (diff)
downloadgentoo-5b6549e04a6ee0edac7d182caba010991c35007d.tar.gz
gentoo-5b6549e04a6ee0edac7d182caba010991c35007d.tar.bz2
gentoo-5b6549e04a6ee0edac7d182caba010991c35007d.zip
sys-apps/sed: Removed old.
Package-Manager: Portage-2.3.42, Repoman-2.3.9
-rw-r--r--sys-apps/sed/Manifest1
-rw-r--r--sys-apps/sed/files/sed-4.1.5-alloca.patch14
-rw-r--r--sys-apps/sed/sed-4.2.2.ebuild61
3 files changed, 0 insertions, 76 deletions
diff --git a/sys-apps/sed/Manifest b/sys-apps/sed/Manifest
index ec23d184ad72..a93fc1f8ff9a 100644
--- a/sys-apps/sed/Manifest
+++ b/sys-apps/sed/Manifest
@@ -1,2 +1 @@
-DIST sed-4.2.2.tar.bz2 1059414 BLAKE2B aebe0bf90e9f9c7907e0baa8a4d1a16e59a5893198382fb9fe08ed66cab670921c0db1e07f668bf3db8dfe9bb4f0e68b9c34fd7228c70df24be043d3e7ea8d92 SHA512 dbbb0bb348fac54612d29182c09c88bda7096dea03bd94f03c580c24146e65a06db12808c6a1a9adc94548fa3843511e3e80b251cb07142110cf149eab23f573
DIST sed-4.5.tar.xz 1274252 BLAKE2B 08525659e0e01ec50e736c1665634f3816f57c48aeefa7f6bc7a152cd6c171bb4e96e5c215429fc5edbe6e1de6cc3efe4f2f3bf6865933a30dd1700e921d5b3f SHA512 f95fb27e03b2301dae63878413b4c48e40341cc676945a612e1d0bd911da3192858ae142791292a99fbdaacbc7dab2d6fccb50787c06846f99b0b3740b40c196
diff --git a/sys-apps/sed/files/sed-4.1.5-alloca.patch b/sys-apps/sed/files/sed-4.1.5-alloca.patch
deleted file mode 100644
index 89679c5362e3..000000000000
--- a/sys-apps/sed/files/sed-4.1.5-alloca.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-fix building on BSD systems which often do not have alloca.h
-
---- sed-4.1.5/lib/regex_internal.h
-+++ sed-4.1.5/lib/regex_internal.h
-@@ -410,7 +410,9 @@ static unsigned int re_string_context_at
- #define re_string_skip_bytes(pstr,idx) ((pstr)->cur_idx += (idx))
- #define re_string_set_index(pstr,idx) ((pstr)->cur_idx = (idx))
-
-+#ifdef HAVE_ALLOCA_H
- #include <alloca.h>
-+#endif
-
- #ifndef _LIBC
- # if HAVE_ALLOCA
diff --git a/sys-apps/sed/sed-4.2.2.ebuild b/sys-apps/sed/sed-4.2.2.ebuild
deleted file mode 100644
index b6da5a256ce2..000000000000
--- a/sys-apps/sed/sed-4.2.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="acl nls selinux static"
-
-RDEPEND="acl? ( virtual/acl )
- nls? ( virtual/libintl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786
- if ! type -p sed > /dev/null ; then
- mkdir -p "${T}/bootstrap"
- printf '#!/bin/sh\nexec busybox sed "$@"\n' > "${T}/bootstrap/sed" || die
- chmod a+rx "${T}/bootstrap/sed"
- PATH="${T}/bootstrap:${PATH}"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.1.5-alloca.patch
-
- # don't use sed before bootstrap if we have to recover a broken host sed
- src_bootstrap_sed
- # this has to be after the bootstrap portion
- sed -i \
- -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
- doc/Makefile.in || die "sed html doc"
-}
-
-src_configure() {
- local myconf=()
- if use userland_GNU; then
- myconf+=( --exec-prefix="${EPREFIX}" )
- else
- myconf+=( --program-prefix=g )
- fi
-
- # Should be able to drop this hack in next release. #333887
- tc-is-cross-compiler && export gl_cv_func_working_acl_get_file=yes
- export ac_cv_search_setfilecon=$(usex selinux -lselinux)
- export ac_cv_header_selinux_{context,selinux}_h=$(usex selinux)
- use static && append-ldflags -static
- econf \
- $(use_enable acl) \
- $(use_enable nls) \
- "${myconf[@]}"
-}