summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 01:14:30 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:38 +0000
commit5b85a1687900b93ed9e9cbf17481157c80e394a4 (patch)
tree27fb063f608566d84d61bb7c1e6e89b1d8bb812f
parentapp-misc/ca-certificates: add 20230311.3.96.1 (diff)
downloadgentoo-5b85a1687900b93ed9e9cbf17481157c80e394a4.tar.gz
gentoo-5b85a1687900b93ed9e9cbf17481157c80e394a4.tar.bz2
gentoo-5b85a1687900b93ed9e9cbf17481157c80e394a4.zip
mate-base/caja: add 1.26.3, 1.27.2
clean up deps in 1.27.2 Closes: https://bugs.gentoo.org/859532 Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mate-base/caja/Manifest2
-rw-r--r--mate-base/caja/caja-1.26.3.ebuild92
-rw-r--r--mate-base/caja/caja-1.27.2.ebuild89
3 files changed, 183 insertions, 0 deletions
diff --git a/mate-base/caja/Manifest b/mate-base/caja/Manifest
index 07dd594ae3c7..6fa0b411f14a 100644
--- a/mate-base/caja/Manifest
+++ b/mate-base/caja/Manifest
@@ -1,2 +1,4 @@
DIST caja-1.26.0.tar.xz 5283368 BLAKE2B 8449d7d721a997458102abf0fefcb35734a1b254280a4b8baa14667913f2a3006c31583d956de54ad7fac9e1da70057e058547eb7e3652a1dca9df9e9628a3a9 SHA512 0abbaebe6dc24644d0e5057fe79e57f67a1e5208f6aa89289649e6e1940285e4c169ec42197ae933f663a9c69a7f09295003cc645492db6abbd9ebce7085c03a
DIST caja-1.26.1.tar.xz 5263564 BLAKE2B 44cdbbc86a24d9d3d6f7830ba45dd82a69b0aadd233531a97ab1cc4dfc5f7466543d70d3f8d6cef4bc669c0ab12b77ca7f22d40f486f36e80c4103c992369002 SHA512 e5d14d1a5f0ae9f86d3250e5a2d10a4e0afdc7ba1b52fcac4c8efc0a4c555d0208be3caf3aac19cc4938fe4c20e82f1f81d259d30e5d8fffbc78708664d23d4e
+DIST caja-1.26.3.tar.xz 5276276 BLAKE2B d9347986939433bf3b28b58ab8412579caa5cafddc72880a45dcffef75a5431cc81741a4f7006f1183c2b74cbae673db69ed8191616bd85c262bd07204601efd SHA512 6f17d46de77c552f68c77e0b6a0c388a7fe353ddd5ea5376685aec209f301b5a74a76b1af4c2324f41838ff7251acffa3bd119cf2462a8b8b45ef1b88df4c83c
+DIST caja-1.27.2.tar.xz 5321212 BLAKE2B d2dca7b90afb5c81d7c25f4eb4acf79007f5134f9ad5924fcbb63490d5c3cf303892dd2e43b4a7c3a6f7181cade24cd785c8f7cae93e3fed121553e3993874f2 SHA512 ca36533e0dfb583aaf8bdc6f1d3e5235a4e0b67e6c3d6180d76cd8c52ba72b224a73ccbe4868310cc318b083fe96ac62002422d967849eba88da20e0ad3a1a4c
diff --git a/mate-base/caja/caja-1.26.3.ebuild b/mate-base/caja/caja-1.26.3.ebuild
new file mode 100644
index 000000000000..f7d34c25f7c5
--- /dev/null
+++ b/mate-base/caja/caja-1.26.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Caja file manager for the MATE desktop"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection +mate nls xmp"
+
+COMMON_DEPEND="
+ || (
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/atk
+ )
+ >=dev-libs/glib-2.58.1:2
+ >=dev-libs/libxml2-2.4.7:2
+ gnome-base/dconf
+ >=gnome-base/gvfs-1.10.1:0[udisks]
+ >=mate-base/mate-desktop-1.17.3:0
+ >=media-libs/libexif-0.6.14:0
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/libnotify-0.7.0:0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=x11-libs/pango-1.1.2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+ xmp? ( >=media-libs/exempi-1.99.5:2= )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5:=
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PDEPEND="mate? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"
+
+# TODO: Test fails because Caja is not merged yet:
+# GLib-GIO-ERROR **: Settings schema 'org.mate.caja.preferences' is not installed
+RESTRICT="test"
+
+src_prepare() {
+ # Remove unnecessary CFLAGS.
+ sed -i -e 's:-DG.*DISABLE_DEPRECATED::g' \
+ configure.ac eel/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --disable-update-mimedb \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ Xemake check || die "Test phase failed"
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ elog "Caja can use gstreamer to preview audio files. Just make sure"
+ elog "to have the necessary plugins available to play the media type you"
+ elog "want to preview."
+}
diff --git a/mate-base/caja/caja-1.27.2.ebuild b/mate-base/caja/caja-1.27.2.ebuild
new file mode 100644
index 000000000000..3bc355112abe
--- /dev/null
+++ b/mate-base/caja/caja-1.27.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="Caja file manager for the MATE desktop"
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection +mate nls xmp"
+
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ >=dev-libs/glib-2.58.1:2
+ >=dev-libs/libxml2-2.4.7:2
+ gnome-base/dconf
+ >=gnome-base/gvfs-1.10.1:0[udisks]
+ >=mate-base/mate-desktop-1.17.3:0
+ >=media-libs/libexif-0.6.14:0
+ virtual/libintl
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.36.5:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/libnotify-0.7.0:0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrender
+ >=x11-libs/pango-1.1.2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
+ xmp? ( >=media-libs/exempi-1.99.5:2= )
+"
+
+BDEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5:=
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PDEPEND="mate? ( >=x11-themes/mate-icon-theme-${MATE_BRANCH} )"
+
+# TODO: Test fails because Caja is not merged yet:
+# GLib-GIO-ERROR **: Settings schema 'org.mate.caja.preferences' is not installed
+RESTRICT="test"
+
+src_prepare() {
+ # Remove unnecessary CFLAGS.
+ sed -i -e 's:-DG.*DISABLE_DEPRECATED::g' \
+ configure.ac eel/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ --disable-update-mimedb \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ unset SESSION_MANAGER
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ Xemake check || die "Test phase failed"
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+
+ elog "Caja can use gstreamer to preview audio files. Just make sure"
+ elog "to have the necessary plugins available to play the media type you"
+ elog "want to preview."
+}