summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-07-18 00:52:27 +0200
committerConrad Kostecki <conikost@gentoo.org>2021-07-18 00:53:04 +0200
commit5ba61e178ded689e1145083b180df6fe8329345e (patch)
tree021415941acbfe9dc060b11752db7b75f83d8083
parentdev-qt/qtdeclarative: riscv: fix missing atomic library (diff)
downloadgentoo-5ba61e178ded689e1145083b180df6fe8329345e.tar.gz
gentoo-5ba61e178ded689e1145083b180df6fe8329345e.tar.bz2
gentoo-5ba61e178ded689e1145083b180df6fe8329345e.zip
app-text/msort: drop libutf8proc patch
Current stable release of dev-libs/libutf8proc does not install anymore into an own subdirectory, so we can drop that patch. Closes: https://bugs.gentoo.org/802585 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--app-text/msort/files/msort-8.53-find-utf8proc-headers.patch33
-rw-r--r--app-text/msort/msort-8.53.ebuild3
2 files changed, 1 insertions, 35 deletions
diff --git a/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch b/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch
deleted file mode 100644
index 9b3845bc601c..000000000000
--- a/app-text/msort/files/msort-8.53-find-utf8proc-headers.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/configure.ac 2010-01-11 01:56:36.000000000 +0100
-+++ b/configure.ac 2018-09-27 15:05:20.205734233 +0200
-@@ -94,7 +94,7 @@
- AC_CHECK_HEADERS([alloca.h ctype.h errno.h gnu/libc-version.h langinfo.h libintl.h limits.h locale.h stdargs.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/stat.h time.h tre/tre.h unicode/umachine.h unicode/unorm.h uninum/unicode.h uninum/nsdefs.h uninum/uninum.h unistd.h wchar.h wctype.h])
-
- if ${utf8proc}; then
--AC_CHECK_HEADER([utf8proc.h],[AC_DEFINE([HAVE_UTF8PROC_H], [1],[Define to 1 if you have <utf8proc.h>.])],[AC_MSG_ERROR([LIB UTF8PROC and its header is obligatory. See http://www.flexiguided.de/publications.utf8proc.en.html])])
-+AC_CHECK_HEADER([libutf8proc/utf8proc.h],[AC_DEFINE([HAVE_UTF8PROC_H], [1],[Define to 1 if you have <libutf8proc/utf8proc.h>.])],[AC_MSG_ERROR([LIB UTF8PROC and its header is obligatory. See http://www.flexiguided.de/publications.utf8proc.en.html])])
- fi
-
- if ${uninum}; then
---- a/misc.c 2009-08-05 05:09:21.000000000 +0200
-+++ b/misc.c 2018-09-27 15:10:37.355738021 +0200
-@@ -41,7 +41,7 @@
- #include <unicode/umachine.h>
- #include <unicode/unorm.h>
- #else
--#include <utf8proc.h>
-+#include <libutf8proc/utf8proc.h>
- #include "unorm.h"
- #endif
- #include <tre/regex.h>
---- a/msort.c 2010-01-11 01:53:32.000000000 +0100
-+++ b/msort.c 2018-09-27 15:10:30.275737936 +0200
-@@ -57,7 +57,7 @@
- #ifndef USEUTF8PROC
- #include <unicode/unorm.h>
- #else
--#include <utf8proc.h>
-+#include <libutf8proc/utf8proc.h>
- #include "unorm.h"
- #endif
- #ifdef HAVE_UNINUM_UNICODE_H
diff --git a/app-text/msort/msort-8.53.ebuild b/app-text/msort/msort-8.53.ebuild
index d70c5e1bf098..62a6fff19ef6 100644
--- a/app-text/msort/msort-8.53.ebuild
+++ b/app-text/msort/msort-8.53.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,6 @@ RDEPEND="dev-libs/tre
DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}/${P}-find-utf8proc-headers.patch"
"${FILESDIR}/${P}-fix-icu-build.patch"
"${FILESDIR}/${P}-fix-missing-limits-header.patch"
"${FILESDIR}/${P}-fix-segfault-on-certain-input.patch"